summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:08:27 +0200
committerChristopher Reimer2015-06-08 11:08:27 +0200
commit65b5f71a0c3dbb0134c473df3af87dbd0d097017 (patch)
tree0dea45970fa0920a59670b175c2aa8861fa068c0
downloadaur-65b5f71a0c3dbb0134c473df3af87dbd0d097017.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO31
-rw-r--r--50-live.conf24
-rw-r--r--PKGBUILD62
-rw-r--r--vdr-live.install17
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c4035f988e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = vdr-live
+ pkgdesc = Adds the possibility to control VDR and some of it's plugins by a web interface.
+ pkgver = 0.3.0_21_g6ea279a
+ pkgrel = 1
+ epoch = 1
+ url = http://projects.vdr-developer.org/projects/plg-live
+ install = vdr-live.install
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ depends = pcre
+ depends = tntnet
+ depends = vdr-api=2.2.0
+ optdepends = vdr-epgsearch: Manage searchtimers
+ optdepends = vdr-streamdev: Stream live TV
+ backup = etc/vdr/conf.avail/50-live.conf
+ source = git://projects.vdr-developer.org/vdr-plugin-live.git#commit=6ea279a74a84b13aa72237448c9ed848c8fdcad4
+ source = live-folderstatecookie-v2.diff::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=34407
+ source = live-osd-patch_150221.diff::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=37780
+ source = 50-live.conf
+ md5sums = SKIP
+ md5sums = 6abb3d1724057e765e98e1a9b5326fe3
+ md5sums = c045e5e6ec376eebee834e6dc178327c
+ md5sums = 563961eb90d9f2b3d2a0a34472ef51ee
+
+pkgname = vdr-live
+
diff --git a/50-live.conf b/50-live.conf
new file mode 100644
index 000000000000..a3cdf5984836
--- /dev/null
+++ b/50-live.conf
@@ -0,0 +1,24 @@
+[live]
+#--port=PORT
+# use PORT to listen for incoming connections
+# (default: 8008)
+
+#--ip=IP
+# bind server only to specified IP, may appear multiple times
+# (default: 0.0.0.0)
+
+#--sslport=PORT
+# use PORT to listen for incoming ssl connections
+# (default: 8443)
+
+#--cert=CERT
+# full path to a custom ssl certificate file
+
+#--key=KEY
+# full path to a custom ssl certificate key file
+
+#--log=level
+# log level for tntnet (values: WARN, ERROR, INFO, DEBUG, TRACE)
+
+#--epgimages=<dir>
+# directory for epgimages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..851db208294b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-live
+pkgver=0.3.0_21_g6ea279a
+epoch=1
+_gitver=6ea279a74a84b13aa72237448c9ed848c8fdcad4
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc="Adds the possibility to control VDR and some of it's plugins by a web interface."
+url="http://projects.vdr-developer.org/projects/plg-live"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('pcre' 'tntnet' "vdr-api=${_vdrapi}")
+optdepends=('vdr-epgsearch: Manage searchtimers'
+ 'vdr-streamdev: Stream live TV')
+makedepends=('git')
+install="$pkgname.install"
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("git://projects.vdr-developer.org/vdr-plugin-live.git#commit=$_gitver"
+ 'live-folderstatecookie-v2.diff::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=34407'
+ 'live-osd-patch_150221.diff::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=37780'
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('SKIP'
+ '6abb3d1724057e765e98e1a9b5326fe3'
+ 'c045e5e6ec376eebee834e6dc178327c'
+ '563961eb90d9f2b3d2a0a34472ef51ee')
+pkgver() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git describe --tags | sed -e 's/release_//g' -e 's/-/\./' -e 's/-/\./' -e 's/-/_/g'
+}
+
+prepare() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+
+ # Remove some files. Otherwise patch complains with a dirty src dir
+ rm -f osd_status.{cpp,h}
+ rm -f pages/osd.ecpp
+
+ patch -p1 -i "$srcdir/live-folderstatecookie-v2.diff"
+ patch -p1 -i "$srcdir/live-osd-patch_150221.diff"
+
+ # Use the more modern ResourceDirectory in /usr/share instead of /var/lib
+ sed -i 's/cPlugin::ConfigDirectory/cPlugin::ResourceDirectory/g' live.cpp
+}
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make DESTDIR="$pkgdir" install
+
+ # Copy resource files
+ mkdir -p "$pkgdir/usr/share/vdr/plugins"
+ cp -r live "$pkgdir/usr/share/vdr/plugins"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}
diff --git a/vdr-live.install b/vdr-live.install
new file mode 100644
index 000000000000..b37bfe2e3df8
--- /dev/null
+++ b/vdr-live.install
@@ -0,0 +1,17 @@
+post_install() {
+ mkdir -p /var/lib/vdr/plugins/live
+ cd /var/lib/vdr/plugins/live
+ if [ ! -e live.pem ] || [ ! -e live-key.pem ]; then
+ openssl req -new -x509 -keyout live-key.pem -out live.pem -days 9999 -nodes -batch
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ rm /var/lib/vdr/plugins/live/live.pem
+ rm /var/lib/vdr/plugins/live/live-key.pem
+ rmdir /var/lib/vdr/plugins/live 2> /dev/null
+}