summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2020-04-12 17:03:26 +0200
committerManuel Reimer2020-04-12 17:03:26 +0200
commiteea66063a8bf66bc38d45195ebb18f164676bb69 (patch)
treeb041363481e68ba587ef100883f15b89a1588b27
parent258a33943fefe87b82c3e81eb1ddc47c51d1949c (diff)
downloadaur-eea66063a8bf66bc38d45195ebb18f164676bb69.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/bf1a74fad99459a54b71ced6d85b29b512f74993)
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--vdr-markad-ffmpeg4-fix.patch86
-rw-r--r--vdr-markad-newmakefile.diff150
4 files changed, 26 insertions, 273 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 374641cd4b35..b28ff4f98a9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,26 @@
-# Generated by makepkg 5.1.3
-# Tue Jun 18 20:45:58 UTC 2019
+# Generated by makepkg 5.2.1
+# Sun Apr 12 15:03:26 UTC 2020
pkgbase = vdr-markad
pkgdesc = automatic advertisement detection
- pkgver = 0.1.4_45_gea2e182
- pkgrel = 3
+ pkgver = 1.0.3
+ pkgrel = 1
epoch = 1
- url = http://projects.vdr-developer.org/projects/plg-markad
+ url = https://github.com/kfb77/vdr-plugin-markad
arch = x86_64
arch = i686
arch = arm
arch = armv6h
arch = armv7h
license = GPL2
- makedepends = git
depends = ffmpeg
depends = vdr-api=2.4.1
backup = etc/vdr/conf.avail/50-markad.conf
- source = git+https://projects.vdr-developer.org/git/vdr-plugin-markad.git#commit=ea2e182ec798375f3830f8b794e7408576f139ad
- source = vdr-markad-ffmpeg4-fix.patch
- source = vdr-markad-newmakefile.diff
+ source = vdr-markad-1.0.3.tar.gz::https://github.com/kfb77/vdr-plugin-markad/archive/v1.0.3.tar.gz
+ source = vdr-markad-logos-1.tar.bz2::https://projects.vdr-developer.org/git/vdr-plugin-markad.git/snapshot/vdr-plugin-markad-ea2e182ec798375f3830f8b794e7408576f139ad.tar.bz2
source = 50-markad.conf
- md5sums = SKIP
- md5sums = 118d57db2dd99bf5fbb829e2e55887ed
- md5sums = 77001bbf5f138d1d1cd7a6f334fa8202
- md5sums = c0d6383c9c9b8ee6c34af19179676bf3
+ sha256sums = 087b5300da3841d7790afdfa23aeaf1511cf5c848bb30a2c3532de8c3b9162f7
+ sha256sums = c5316bd48ebdb58ecad8bf8de29b2b92337aa8350a4d3340e8383301d4f7719f
+ sha256sums = 614cbd493d5556249d17598a4a0a43eacfc084e9c0446b27f0cf6ff846dd8640
pkgname = vdr-markad
diff --git a/PKGBUILD b/PKGBUILD
index abf56c3a7d32..9f0cea8c0fc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,42 @@
# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
-# Maintainer: Alexander Grothe <seahawk1986[at]hotmail[dot]com>
+# Maintainer: Manuel Reimer <manuel.reimer@gmx.de>
pkgname=vdr-markad
-pkgver=0.1.4_45_gea2e182
+pkgver=1.0.3
+_logover=ea2e182ec798375f3830f8b794e7408576f139ad
epoch=1
-_gitver=ea2e182ec798375f3830f8b794e7408576f139ad
_vdrapi=2.4.1
-pkgrel=3
+pkgrel=1
pkgdesc="automatic advertisement detection"
-url="http://projects.vdr-developer.org/projects/plg-markad"
+url="https://github.com/kfb77/vdr-plugin-markad"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('ffmpeg' "vdr-api=${_vdrapi}")
-makedepends=('git')
_plugname=${pkgname//vdr-/}
-source=("git+https://projects.vdr-developer.org/git/vdr-plugin-markad.git#commit=$_gitver"
- "vdr-markad-ffmpeg4-fix.patch"
- "vdr-markad-newmakefile.diff"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kfb77/vdr-plugin-markad/archive/v1.0.3.tar.gz"
+ "$pkgname-logos-1.tar.bz2::https://projects.vdr-developer.org/git/vdr-plugin-markad.git/snapshot/vdr-plugin-markad-$_logover.tar.bz2"
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-md5sums=('SKIP'
- '118d57db2dd99bf5fbb829e2e55887ed'
- '77001bbf5f138d1d1cd7a6f334fa8202'
- 'c0d6383c9c9b8ee6c34af19179676bf3')
-
-pkgver() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
- git describe --tags | sed 's/-/_/g;s/v//'
-}
+sha256sums=('087b5300da3841d7790afdfa23aeaf1511cf5c848bb30a2c3532de8c3b9162f7'
+ 'c5316bd48ebdb58ecad8bf8de29b2b92337aa8350a4d3340e8383301d4f7719f'
+ '614cbd493d5556249d17598a4a0a43eacfc084e9c0446b27f0cf6ff846dd8640')
prepare() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
- patch -p1 -i "$srcdir/vdr-markad-newmakefile.diff"
- patch -p1 -i "$srcdir/vdr-markad-ffmpeg4-fix.patch"
+ cd "${srcdir}/vdr-plugin-${_plugname}-$pkgver"
+ rm -rf "command/logos"
+ mv "${srcdir}/vdr-plugin-$_plugname-$_logover/command/logos" "command"
}
build() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-$pkgver"
make
}
package() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-$pkgver"
make DESTDIR="$pkgdir" install
- #Move the logofiles to the right place and add a symlink to workaround patching.
+ # Move the logofiles to the right place and add a symlink to prevent patching.
mkdir -p "$pkgdir/usr/share"
mv "$pkgdir/var/lib/markad" "$pkgdir/usr/share/markad"
ln -s /usr/share/markad "$pkgdir/var/lib/markad"
diff --git a/vdr-markad-ffmpeg4-fix.patch b/vdr-markad-ffmpeg4-fix.patch
deleted file mode 100644
index bb943d2d038a..000000000000
--- a/vdr-markad-ffmpeg4-fix.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff --git a/command/decoder.cpp b/command/decoder.cpp
-index 6400aa7..8cb14b9 100644
---- a/command/decoder.cpp
-+++ b/command/decoder.cpp
-@@ -180,16 +180,22 @@ cMarkAdDecoder::cMarkAdDecoder(bool useH264, int Threads)
- }
- else
- {
-+#ifdef AV_CODEC_ID_MPEG2VIDEO_XVMC
- video_codecid=AV_CODEC_ID_MPEG2VIDEO_XVMC;
-+#else
-+ video_codecid=AV_CODEC_ID_MPEG2VIDEO;
-+#endif
- }
-
- video_codec = avcodec_find_decoder(video_codecid);
-+#ifdef AV_CODEC_ID_MPEG2VIDEO_XVMC
- if ((!video_codec) && (video_codecid==AV_CODEC_ID_MPEG2VIDEO_XVMC))
- {
- // fallback to MPEG2VIDEO
- video_codecid=AV_CODEC_ID_MPEG2VIDEO;
- video_codec=avcodec_find_decoder(video_codecid);
- }
-+#endif
-
- if (video_codec)
- {
-@@ -200,17 +206,17 @@ cMarkAdDecoder::cMarkAdDecoder(bool useH264, int Threads)
- #endif
- if (video_context)
- {
-- if (video_codec->capabilities & CODEC_CAP_TRUNCATED)
-- video_context->flags|=CODEC_FLAG_TRUNCATED; // we do not send complete frames
-- video_context->flags|=CODEC_FLAG_LOW_DELAY;
-- video_context->flags2|=CODEC_FLAG2_FAST; // really?
-+ if (video_codec->capabilities & AV_CODEC_CAP_TRUNCATED)
-+ video_context->flags|=AV_CODEC_FLAG_TRUNCATED; // we do not send complete frames
-+ video_context->flags|=AV_CODEC_FLAG_LOW_DELAY;
-+ video_context->flags2|=AV_CODEC_FLAG2_FAST; // really?
- video_context->skip_idct=AVDISCARD_ALL;
-
- if (video_codecid!=AV_CODEC_ID_H264)
- {
- video_context->skip_frame=AVDISCARD_NONKEY; // just I-frames
- } else {
-- video_context->flags2|=CODEC_FLAG2_CHUNKS;
-+ video_context->flags2|=AV_CODEC_FLAG2_CHUNKS;
- #if LIBAVCODEC_VERSION_INT >= ((52<<16)+(47<<8)+0)
- av_log_set_level(AV_LOG_FATAL); // silence decoder output
- #else
-@@ -224,7 +230,11 @@ cMarkAdDecoder::cMarkAdDecoder(bool useH264, int Threads)
- #else
- int ret=avcodec_open(video_context, video_codec);
- #endif
-+#ifdef AV_CODEC_ID_MPEG2VIDEO_XVMC
- if ((ret < 0) && (video_codecid==AV_CODEC_ID_MPEG2VIDEO_XVMC))
-+#else
-+ if (ret < 0)
-+#endif
- {
- // fallback to MPEG2VIDEO
- video_codecid=AV_CODEC_ID_MPEG2VIDEO;
-@@ -256,9 +266,11 @@ cMarkAdDecoder::cMarkAdDecoder(bool useH264, int Threads)
- case AV_CODEC_ID_H264:
- esyslog("could not open codec for H264");
- break;
-+#ifdef AV_CODEC_ID_MPEG2VIDEO_XVMC
- case AV_CODEC_ID_MPEG2VIDEO_XVMC:
- esyslog("could not open codec MPEG2 (XVMC)");
- break;
-+#endif
- case AV_CODEC_ID_MPEG2VIDEO:
- esyslog("could not open codec MPEG2");
- break;
-@@ -322,9 +334,11 @@ cMarkAdDecoder::cMarkAdDecoder(bool useH264, int Threads)
- case AV_CODEC_ID_H264:
- esyslog("codec for H264 not found");
- break;
-+#ifdef AV_CODEC_ID_MPEG2VIDEO_XVMC
- case AV_CODEC_ID_MPEG2VIDEO_XVMC:
- esyslog("codec for MPEG2 (XVMC) not found");
- break;
-+#endif
- case AV_CODEC_ID_MPEG2VIDEO:
- esyslog("codec for MPEG2 not found");
- break;
diff --git a/vdr-markad-newmakefile.diff b/vdr-markad-newmakefile.diff
deleted file mode 100644
index eef11dc8aa4d..000000000000
--- a/vdr-markad-newmakefile.diff
+++ /dev/null
@@ -1,150 +0,0 @@
-diff --git a/plugin/Makefile b/plugin/Makefile
-index 2f51502..550c1f2 100644
---- a/plugin/Makefile
-+++ b/plugin/Makefile
-@@ -1,54 +1,51 @@
- #
- # Makefile for a Video Disk Recorder plugin
-+# Adapted to the new VDR makefile environment by Stefan Hofmann
- #
-+# $Id: $
-
- # The official name of this plugin.
- # This name will be used in the '-P...' option of VDR to load the plugin.
- # By default the main source file also carries this name.
--# IMPORTANT: the presence of this macro is important for the Make.config
--# file. So it must be defined, even if it is not used here!
--#
--PLUGIN = markad
--
--### The version number of this plugin (taken from the main source file):
-
--$(shell GITVERSION=`git rev-parse --short HEAD 2> /dev/null`; if [ "$$GITVERSION" ]; then sed "s/\";/ ($$GITVERSION)\";/" ../version.dist > ../version.h; else cp ../version.dist ../version.h; fi)
--VERSION = $(shell grep 'static const char \*VERSION *=' ../version.h | awk '{ print $$6 }' | sed -e 's/[";]//g')
-+PLUGIN = markad
-
--### The C++ compiler and options:
-+### The version number of this plugin (taken from the version header file):
-
--CXX ?= g++
--CXXFLAGS ?= -fPIC -g -O2 -Wall -Wextra -Woverloaded-virtual -Wno-parentheses
-+VERSION = $(shell grep 'static const char \*VERSION *=' version.h | awk '{ print $$6 }' | sed -e 's/[";]//g')
-
- ### The directory environment:
-
--VDRDIR ?= ../../../..
--LIBDIR ?= ../../../lib
-+# Use package data if installed...otherwise assume we're under the VDR source directory:
-+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell PKG_CONFIG_PATH="$$PKG_CONFIG_PATH:../../.." pkg-config --variable=$(1) vdr))
-+LIBDIR = $(call PKGCFG,libdir)
-+LOCDIR = $(call PKGCFG,locdir)
-+#
- TMPDIR ?= /tmp
-
--### Make sure that necessary options are included:
--
---include $(VDRDIR)/Make.global
-+### The compiler options:
-
--### Allow user defined options to overwrite defaults:
-+export CFLAGS = $(call PKGCFG,cflags)
-+export CXXFLAGS = $(call PKGCFG,cxxflags)
-
---include $(VDRDIR)/Make.config
-+### The version number of VDR's plugin API:
-
--### The version number of VDR's plugin API (taken from VDR's "config.h"):
--
--APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
-+APIVERSION = $(call PKGCFG,apiversion)
-
- ### The name of the distribution archive:
-
- ARCHIVE = $(PLUGIN)-$(VERSION)
- PACKAGE = vdr-$(ARCHIVE)
-
-+### The name of the shared object file:
-+
-+SOFILE = libvdr-$(PLUGIN).so
-+
- ### Includes and Defines (add further entries here):
-
--INCLUDES += -I$(VDRDIR)/include
-+INCLUDES +=
-
--DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
--DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
-
- ### The object files (add further files here):
-
-@@ -56,12 +53,12 @@ OBJS = $(PLUGIN).o status.o menu.o setup.o
-
- ### The main target:
-
--all: libvdr-$(PLUGIN).so i18n
-+all: $(SOFILE) i18n
-
- ### Implicit rules:
-
- %.o: %.cpp
-- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
-+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
-
- ### Dependencies:
-
-@@ -75,36 +72,39 @@ $(DEPFILE): Makefile
- ### Internationalization (I18N):
-
- PODIR = po
--LOCALEDIR = $(VDRDIR)/locale
- I18Npo = $(wildcard $(PODIR)/*.po)
--I18Nmsgs = $(addprefix $(LOCALEDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
-+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
-+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
- I18Npot = $(PODIR)/$(PLUGIN).pot
-
- %.mo: %.po
- msgfmt -c -o $@ $<
-
- $(I18Npot): $(wildcard *.cpp *.h)
-- xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --msgid-bugs-address='<see README>' -o $@ $^
-+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<vdr@dolze.de>' -o $@ `ls $^`
-
- %.po: $(I18Npot)
-- msgmerge -U --no-wrap --no-location --backup=none -q $@ $<
-+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
- @touch $@
-
--$(I18Nmsgs): $(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
-- @mkdir -p $(dir $@)
-- cp $< $@
-+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
-+ install -D -m644 $< $@
-
- .PHONY: i18n
--i18n: $(I18Nmsgs) $(I18Npot)
-+i18n: $(I18Nmo) $(I18Npot)
-+
-+install-i18n: $(I18Nmsgs)
-
- ### Targets:
-
--install: all
-- cp --remove-destination libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-+$(SOFILE): $(OBJS)
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
-+
-+install-lib: $(SOFILE)
-+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
-
--libvdr-$(PLUGIN).so: $(OBJS)
-- $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -o $@
-- cp --remove-destination libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-+install: install-lib install-i18n
-
- clean:
-- @-rm -f $(OBJS) $(DEPFILE) *.so *.so.* *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
-+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
-+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
-