summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:10:22 +0200
committerChristopher Reimer2015-06-08 11:10:22 +0200
commit33e8a9a9b50749c0b6dbcb963447bcaf7eaadec3 (patch)
treeca4457b6886939a249321beaa054e616293d7a36
downloadaur-33e8a9a9b50749c0b6dbcb963447bcaf7eaadec3.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO34
-rw-r--r--50-mp3.conf24
-rw-r--r--50-mplayer.conf12
-rw-r--r--PKGBUILD68
-rw-r--r--mp3-vdr2.1.2compat.diff30
5 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27be366f9e61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = vdr-mp3
+ pkgver = 0.10.2
+ pkgrel = 15
+ url = http://www.muempf.de/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = gcc-libs
+ depends = libid3tag
+ depends = libmad
+ depends = libsndfile
+ depends = vdr-api=2.2.0
+ source = http://www.muempf.de/down/vdr-mp3-0.10.2.tar.gz
+ source = mp3-vdr2.1.2compat.diff
+ source = 50-mp3.conf
+ source = 50-mplayer.conf
+ md5sums = 66fd37827326776c223a0fdd0ad3811e
+ md5sums = 8615c6b0f3c5eba39e8e2ce37c5c10a4
+ md5sums = 16d931040572e628e01a6f6774c8ff27
+ md5sums = be1ce6311b271b29306a96ec664c40d4
+
+pkgname = vdr-mp3
+ pkgdesc = Allows playback of MP3 and other audio files.
+ backup = var/lib/vdr/plugins/mp3sources.conf
+ backup = etc/vdr/conf.avail/50-mp3.conf
+
+pkgname = vdr-mplayer
+ pkgdesc = Call MPlayer for playback of video
+ backup = var/lib/vdr/plugins/mp3sources.conf
+ backup = etc/vdr/conf.avail/50-mp3.conf
+
diff --git a/50-mp3.conf b/50-mp3.conf
new file mode 100644
index 000000000000..c9820e44d00b
--- /dev/null
+++ b/50-mp3.conf
@@ -0,0 +1,24 @@
+[mp3]
+#--mount=CMD
+# use CMD to mount/unmount/eject mp3 sources (default: mount.sh)
+
+#--network=CMD
+# execute CMD before & after network access (default: none)
+
+#--cache=DIR
+# store ID3 cache file in DIR(default: video dir)
+
+#--cddb=DIR
+# search CDDB files in DIR (default: /var/lib/cddb)
+
+#--iconv=CMD
+# use CMD to convert background images (default: image_convert.sh)
+
+#--defimage=IMG
+# use IMG as default background image (default: none)
+
+#--icache=DIR
+# cache converted images in DIR (default: /var/cache/images/mp3)
+
+#--sources=SUB
+# search sources config in SUB subdirectory(default: none) \ No newline at end of file
diff --git a/50-mplayer.conf b/50-mplayer.conf
new file mode 100644
index 000000000000..4f39689ff39a
--- /dev/null
+++ b/50-mplayer.conf
@@ -0,0 +1,12 @@
+[mplayer]
+#--mount=CMD
+# use CMD to mount/unmount/eject mp3 sources (default: mount.sh)
+
+#--mplayer=CMD
+# use CMD when calling MPlayer (default: mplayer.sh)
+
+#--sources=SUB
+# search sources config in SUB subdirectory (default: none)
+
+#--resume=DIR
+# store global resume file in DIR (default: video dir)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf46af370d9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgbase=vdr-mp3
+pkgname=('vdr-mp3' 'vdr-mplayer')
+pkgver=0.10.2
+_vdrapi=2.2.0
+pkgrel=15
+url="http://www.muempf.de/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' 'libid3tag' 'libmad' 'libsndfile' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgbase | sed 's/vdr-//g')
+source=("http://www.muempf.de/down/$pkgbase-$pkgver.tar.gz"
+ 'mp3-vdr2.1.2compat.diff'
+ "50-mp3.conf"
+ "50-mplayer.conf")
+md5sums=('66fd37827326776c223a0fdd0ad3811e'
+ '8615c6b0f3c5eba39e8e2ce37c5c10a4'
+ '16d931040572e628e01a6f6774c8ff27'
+ 'be1ce6311b271b29306a96ec664c40d4')
+
+prepare() {
+ cd "$srcdir/$_plugname-$pkgver"
+ patch -p1 -i "$srcdir/mp3-vdr2.1.2compat.diff"
+}
+
+package_vdr-mp3() {
+ pkgdesc="Allows playback of MP3 and other audio files."
+ _plugname=$(echo $pkgname | sed 's/vdr-//g')
+ backup=("var/lib/vdr/plugins/${_plugname}sources.conf"
+ "etc/vdr/conf.avail/50-$_plugname.conf")
+ cd "$srcdir/$_plugname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib/vdr/plugins"
+ make CFLAGS="$(pkg-config vdr --variable=cflags)" \
+ CXXFLAGS="$(pkg-config vdr --variable=cxxflags)" \
+ VDRDIR="/usr" \
+ LIBDIR="$pkgdir/$(pkg-config vdr --variable=libdir)" \
+ LOCALEDIR="$pkgdir/$(pkg-config vdr --variable=locdir)" \
+ WITHOUT_MPLAYER=1
+ install -Dm644 examples/mp3sources.conf.example "$pkgdir/var/lib/vdr/plugins/mp3sources.conf"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+
+ chown -R 666:666 "$pkgdir/var/lib/vdr"
+}
+
+package_vdr-mplayer() {
+ pkgdesc="Call MPlayer for playback of video"
+ _plugname=$(echo $pkgname | sed 's/vdr-//g')
+ backup=("var/lib/vdr/plugins/${_plugname}sources.conf"
+ "etc/vdr/conf.avail/50-$_plugname.conf")
+ cd "$srcdir/mp3-$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib/vdr/plugins"
+ make CFLAGS="$(pkg-config vdr --variable=cflags)" \
+ CXXFLAGS="$(pkg-config vdr --variable=cxxflags)" \
+ VDRDIR="/usr" \
+ LIBDIR="$pkgdir/$(pkg-config vdr --variable=libdir)" \
+ LOCALEDIR="$pkgdir/$(pkg-config vdr --variable=locdir)" \
+ WITHOUT_MP3=1
+ install -Dm644 examples/mp3sources.conf.example "$pkgdir/var/lib/vdr/plugins/mplayersources.conf"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+
+ chown -R 666:666 "$pkgdir/var/lib/vdr"
+}
diff --git a/mp3-vdr2.1.2compat.diff b/mp3-vdr2.1.2compat.diff
new file mode 100644
index 000000000000..5ba27e1ff4b9
--- /dev/null
+++ b/mp3-vdr2.1.2compat.diff
@@ -0,0 +1,30 @@
+diff -ruN mp3-0.10.2/decoder.c mp3-0.10.2.edit/decoder.c
+--- mp3-0.10.2/decoder.c 2009-11-29 04:09:45.000000000 +0100
++++ mp3-0.10.2.edit/decoder.c 2013-10-20 18:54:04.001276261 +0200
+@@ -632,7 +632,11 @@
+
+ char *cInfoCache::CacheFile(void)
+ {
++#if APIVERSNUM > 20101
++ return AddPath(cachedir?cachedir:cVideoDirectory::Name(),CACHEFILENAME);
++#else
+ return AddPath(cachedir?cachedir:VideoDirectory,CACHEFILENAME);
++#endif
+ }
+
+ void cInfoCache::Save(bool force)
+diff -ruN mp3-0.10.2/player-mplayer.c mp3-0.10.2.edit/player-mplayer.c
+--- mp3-0.10.2/player-mplayer.c 2009-10-14 00:18:18.000000000 +0200
++++ mp3-0.10.2.edit/player-mplayer.c 2013-10-20 18:57:18.783130016 +0200
+@@ -185,7 +185,11 @@
+ if(MPlayerSetup.ResumeMode==1 ||
+ (access(s,W_OK) && (errno==EACCES || errno==EROFS))) {
+ global=true;
++#if APIVERSNUM > 20101
++ resfile=AddPath(globalResumeDir?globalResumeDir:cVideoDirectory::Name(),GLOBAL_RESUME_FILE);
++#else
+ resfile=AddPath(globalResumeDir?globalResumeDir:VideoDirectory,GLOBAL_RESUME_FILE);
++#endif
+ d(printf("resume: using global file\n"))
+ }
+ else {