summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:09:19 +0200
committerChristopher Reimer2015-06-08 11:09:19 +0200
commit41685ed6675e6904221bd8daf276288321f80895 (patch)
tree7ec0b9b1380502b9ce7632ce369010cbca8bd88d
downloadaur-41685ed6675e6904221bd8daf276288321f80895.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO21
-rw-r--r--50-osdteletext.conf15
-rw-r--r--PKGBUILD30
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ef2c49fa9dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vdr-osdteletext
+ pkgdesc = Displays teletext pages directly on VDR's OSD
+ pkgver = 0.9.5
+ pkgrel = 2
+ url = http://projects.vdr-developer.org/projects/plg-osdteletext
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-osdteletext.conf
+ source = http://projects.vdr-developer.org/git/vdr-plugin-osdteletext.git/snapshot/vdr-plugin-osdteletext-0.9.5.tar.bz2
+ source = 50-osdteletext.conf
+ md5sums = 2d35232f2273d6093061f44d9965ae8a
+ md5sums = 4e47fd8f77cea06d30e07486b7fd9d6e
+
+pkgname = vdr-osdteletext
+
diff --git a/50-osdteletext.conf b/50-osdteletext.conf
new file mode 100644
index 000000000000..a3c5e09a7c80
--- /dev/null
+++ b/50-osdteletext.conf
@@ -0,0 +1,15 @@
+[osdteletext]
+--directory=/tmp
+# The directory where the temporary files will be stored.
+# Ensure that the directory exists and is writable.
+
+#--max-cache=NUM
+# Maximum size in megabytes of cache used to store the pages on the harddisk.
+# (default: a calculated value below 50 MB)
+
+#--cache-system=SYS
+# Set the cache system to be used. Choose "legacy" for the traditional one-file-per-page system.
+# Default is "packed" for the one-file-for-a-few-pages system.
+
+#--toptext
+# Store top text pages at cache. (unviewable pages) \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb66007d159f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-osdteletext
+pkgver=0.9.5
+_vdrapi=2.2.0
+pkgrel=2
+pkgdesc="Displays teletext pages directly on VDR's OSD"
+url="http://projects.vdr-developer.org/projects/plg-osdteletext"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://projects.vdr-developer.org/git/vdr-plugin-$_plugname.git/snapshot/vdr-plugin-$_plugname-$pkgver.tar.bz2"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('2d35232f2273d6093061f44d9965ae8a'
+ '4e47fd8f77cea06d30e07486b7fd9d6e')
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}