summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:07:53 +0200
committerChristopher Reimer2015-06-08 11:07:53 +0200
commit10ba7196e059e51f0f20e88b7c3e2a167911bbf7 (patch)
tree05950b0bd5c3d039d56df1b8c65a57e4d04bb97d
downloadaur-10ba7196e059e51f0f20e88b7c3e2a167911bbf7.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO21
-rw-r--r--50-radio.conf20
-rw-r--r--PKGBUILD33
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea95f06e47b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vdr-radio
+ pkgdesc = Display an background image while the vdr is switched to radio channels
+ pkgver = 1.0.0
+ pkgrel = 16
+ url = http://www.egal-vdr.de/plugins/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-radio.conf
+ source = http://egal-vdr.de/plugins/vdr-radio-1.0.0.tgz
+ source = 50-radio.conf
+ md5sums = c654f7ddeb37aa8088b504d7e2be88ce
+ md5sums = bbb81b2f18c2ee2d54b501e778c00b01
+
+pkgname = vdr-radio
+
diff --git a/50-radio.conf b/50-radio.conf
new file mode 100644
index 000000000000..87321db04d9d
--- /dev/null
+++ b/50-radio.conf
@@ -0,0 +1,20 @@
+[radio]
+--files=/usr/share/vdr/plugins/radio
+# use dir as image directory
+
+--data=/tmp
+# use dir as temp. data directory
+
+--live=/usr/share/vdr/plugins/radio/radio.mpg
+# use file as default mpegfile in livemode
+
+--replay=/usr/share/vdr/plugins/radio/replay.mpg
+# use file as default mpegfile in replaymode
+
+#--encrypted=1
+# use transfermode/backgroundimage @ encrypted radiochannels
+
+#--verbose=level
+# set verbose level (default = 1, 0 = Off, 1 = RDS-Text+Tags,
+# 2 = +RDS-Telegram/Debug, 3 = +RawData 0xfd,
+# += 16 = Rass-Info, +=32 = TMC-Info) \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9fea1bd976f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-radio
+pkgver=1.0.0
+_vdrapi=2.2.0
+pkgrel=16
+pkgdesc="Display an background image while the vdr is switched to radio channels"
+url="http://www.egal-vdr.de/plugins/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://egal-vdr.de/plugins/$pkgname-$pkgver.tgz"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('c654f7ddeb37aa8088b504d7e2be88ce'
+ 'bbb81b2f18c2ee2d54b501e778c00b01')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ #Install all stillpictures
+ mkdir -p "$pkgdir/usr/share/vdr/plugins/$_plugname"
+ install -Dm644 config/mpegstill/* "$pkgdir/usr/share/vdr/plugins/$_plugname"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}