summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:08:42 +0200
committerChristopher Reimer2015-06-08 11:08:42 +0200
commitc2db36e4e2c73823c8695b433a81a7db48586a76 (patch)
tree417e8a5986c66fdf7ec169d4031b857dace1f42e
downloadaur-c2db36e4e2c73823c8695b433a81a7db48586a76.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO25
-rw-r--r--50-remote.conf15
-rw-r--r--70-remote-device.rules3
-rw-r--r--PKGBUILD37
-rw-r--r--av7110_ir_vdr_perms.conf7
5 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c26170a6ad63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vdr-remote
+ pkgdesc = Extends the remote control capabilities of vdr
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://www.escape-edv.de/endriss/vdr/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-remote.conf
+ source = http://www.escape-edv.de/endriss/vdr/vdr-remote-0.6.0.tgz
+ source = av7110_ir_vdr_perms.conf
+ source = 70-remote-device.rules
+ source = 50-remote.conf
+ md5sums = 5c6e60e9a4a0d42ca2b93f3342452202
+ md5sums = bc604e2dff886fb683048590fc5f63c8
+ md5sums = 3e5fa190135b128a575dd90b14c4433a
+ md5sums = 6b163c3d23df45423652f5559f8c6a61
+
+pkgname = vdr-remote
+
diff --git a/50-remote.conf b/50-remote.conf
new file mode 100644
index 000000000000..7a7baed725dd
--- /dev/null
+++ b/50-remote.conf
@@ -0,0 +1,15 @@
+[remote]
+#--input=dev
+# input device (/dev/input/... | autodetect)
+
+#--lirc=dev
+# kernel lirc device (/dev/lircd)
+
+#--port=tcp:n
+# listen on tcp port <n>
+
+#--tty=dev
+# tty device
+
+#--TTY=dev
+# tty device with 'OSD' \ No newline at end of file
diff --git a/70-remote-device.rules b/70-remote-device.rules
new file mode 100644
index 000000000000..737181620625
--- /dev/null
+++ b/70-remote-device.rules
@@ -0,0 +1,3 @@
+# do not edit this file, it will be overwritten on update
+
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{name}=="*dvb*|*DVB*|* IR *", GROUP="vdr" SYMLINK+="input/ir"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a77df84ee89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-remote
+pkgver=0.6.0
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc="Extends the remote control capabilities of vdr"
+url="http://www.escape-edv.de/endriss/vdr/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://www.escape-edv.de/endriss/vdr/${pkgname}-${pkgver}.tgz"
+ 'av7110_ir_vdr_perms.conf'
+ '70-remote-device.rules'
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('5c6e60e9a4a0d42ca2b93f3342452202'
+ 'bc604e2dff886fb683048590fc5f63c8'
+ '3e5fa190135b128a575dd90b14c4433a'
+ '6b163c3d23df45423652f5559f8c6a61')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 ${srcdir}/70-remote-device.rules "$pkgdir/usr/lib/udev/rules.d/70-remote-device.rules"
+ install -Dm644 ${srcdir}/av7110_ir_vdr_perms.conf "$pkgdir/usr/lib/modprobe.d/av7110_ir_vdr_perms.conf"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}
diff --git a/av7110_ir_vdr_perms.conf b/av7110_ir_vdr_perms.conf
new file mode 100644
index 000000000000..e1e538434fe4
--- /dev/null
+++ b/av7110_ir_vdr_perms.conf
@@ -0,0 +1,7 @@
+# Author: Manuel Reimer <manuel.reimer@gmx.de>
+#
+# The following rule automatically changes group and permissions for
+# /proc/av7110_ir, whenever the dvb_ttpci module is reloaded
+#
+
+install dvb_ttpci /sbin/modprobe --ignore-install dvb_ttpci $CMDLINE_OPTS; /usr/bin/test -e /proc/av7110_ir && /bin/chown root:vdr /proc/av7110_ir && /bin/chmod 0664 /proc/av7110_ir