summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:10:05 +0200
committerChristopher Reimer2015-06-08 11:10:05 +0200
commit690c58e8a349900aeaecca2b8d2fd8cecd497c65 (patch)
tree3dec95e7f67c7bda2b5855abd85bc68715d42ae0
downloadaur-690c58e8a349900aeaecca2b8d2fd8cecd497c65.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO23
-rw-r--r--50-sleeptimer.conf3
-rw-r--r--PKGBUILD38
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee58336dafeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = vdr-sleeptimer
+ pkgdesc = Shutdown, mute or execute a custom command after a configurable timespan
+ pkgver = 0.8.2
+ pkgrel = 20
+ url = http://projects.vdr-developer.org/projects/plg-sleeptimer
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-sleeptimer.conf
+ source = http://projects.vdr-developer.org/attachments/download/652/vdr-plugin-sleeptimer-0.8.2.tgz
+ source = vdr-sleeptimer-Makefile::http://projects.vdr-developer.org/git/vdr-plugin-sleeptimer.git/plain/Makefile
+ source = 50-sleeptimer.conf
+ md5sums = cd7012d58d1350a6dc5597dd50a2cd40
+ md5sums = 6045e319c4dc47bc877ae6f331db8049
+ md5sums = 7ac2bda3d2a6238e815a6b04bccf4a81
+
+pkgname = vdr-sleeptimer
+
diff --git a/50-sleeptimer.conf b/50-sleeptimer.conf
new file mode 100644
index 000000000000..618b45e08618
--- /dev/null
+++ b/50-sleeptimer.conf
@@ -0,0 +1,3 @@
+[sleeptimer]
+#-e command
+# shutdown command (default: /sbin/poweroff) \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43a8923b6705
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-sleeptimer
+pkgver=0.8.2
+_vdrapi=2.2.0
+pkgrel=20
+pkgdesc="Shutdown, mute or execute a custom command after a configurable timespan"
+url="http://projects.vdr-developer.org/projects/plg-sleeptimer"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://projects.vdr-developer.org/attachments/download/652/vdr-plugin-$_plugname-$pkgver.tgz"
+ "$pkgname-Makefile::http://projects.vdr-developer.org/git/vdr-plugin-sleeptimer.git/plain/Makefile"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('cd7012d58d1350a6dc5597dd50a2cd40'
+ '6045e319c4dc47bc877ae6f331db8049'
+ '7ac2bda3d2a6238e815a6b04bccf4a81')
+
+prepare() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ cp "$srcdir/$pkgname-Makefile" Makefile
+ sed -i 's/i18n\.o//g' Makefile
+}
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}