summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:09:14 +0200
committerChristopher Reimer2015-06-08 11:09:14 +0200
commitbf6cac77d752bd85e9ad71d305c82e1c89f6ce6b (patch)
tree55b8af8908f5853f6ebb127575525f69dcffe24f
downloadaur-bf6cac77d752bd85e9ad71d305c82e1c89f6ce6b.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO28
-rw-r--r--50-softhddevice.conf53
-rw-r--r--PKGBUILD59
3 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02a2d1477066
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = vdr-softhddevice
+ pkgdesc = software and GPU emulated HD output device plugin for VDR
+ pkgver = 0.6.1rc1_51_gf0d31ad
+ pkgrel = 1
+ epoch = 1
+ url = http://projects.vdr-developer.org/projects/plg-softhddevice
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = AGPL3
+ makedepends = git
+ makedepends = glu
+ depends = ffmpeg
+ depends = mesa
+ depends = vdr-api=2.2.0
+ depends = xcb-util-wm
+ depends = xorg-server
+ optdepends = nvidia: Required for VDPAU decoding
+ backup = etc/vdr/conf.avail/50-softhddevice.conf
+ source = git://projects.vdr-developer.org/vdr-plugin-softhddevice.git#commit=f0d31ad33cf08d39186e08914bbcfa7853126c4c
+ source = 50-softhddevice.conf
+ md5sums = SKIP
+ md5sums = f6ef6cb0bf17c5a28f858e5306776d27
+
+pkgname = vdr-softhddevice
+
diff --git a/50-softhddevice.conf b/50-softhddevice.conf
new file mode 100644
index 000000000000..f53b3c3856e8
--- /dev/null
+++ b/50-softhddevice.conf
@@ -0,0 +1,53 @@
+[softhddevice]
+#-a device
+# audio device (fe. alsa: hw:0,0)
+
+#-c channel
+# audio mixer channel name (fe. PCM)
+
+#-d display
+# display of x11 server (fe. :0.0)
+
+#-D
+# start in detached mode
+
+#-f
+# start with fullscreen window (only with window manager)
+
+#-g geometry
+# x11 window geometry wxh+x+y
+
+#-p device
+# audio device for pass-through (hw:0,1)
+
+#-s
+# start in suspended mode
+
+#-v device
+# video driver device (va-api, vdpau, noop)
+
+#-w workaround
+# enable/disable workarounds
+# no-hw-decoder
+# disable hw decoder, use software decoder only
+# no-mpeg-hw-decoder
+# disable hw decoder for mpeg only
+# still-hw-decoder
+# enable hardware decoder for still-pictures
+# still-h264-hw-decoder
+# enable h264 hw decoder for still-pictures
+# alsa-driver-broken
+# disable broken alsa driver message
+# alsa-no-close-open
+# disable close open to fix alsa no sound bug
+# alsa-close-open-delay
+# enable close open delay to fix no sound bug
+# ignore-repeat-pict
+# disable repeat pict message
+
+#-x
+# start x11 server, with -xx try to connect, if this fails
+
+#-X args
+# X11 server arguments (f.e. -nocursor)
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e93687584537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-softhddevice
+pkgver=0.6.1rc1_51_gf0d31ad
+epoch=1
+_gitver=f0d31ad33cf08d39186e08914bbcfa7853126c4c
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc="software and GPU emulated HD output device plugin for VDR"
+url="http://projects.vdr-developer.org/projects/plg-softhddevice"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('AGPL3')
+depends=('ffmpeg' 'mesa' "vdr-api=${_vdrapi}" 'xcb-util-wm' 'xorg-server')
+optdepends=('nvidia: Required for VDPAU decoding')
+makedepends=('git' 'glu' )
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("git://projects.vdr-developer.org/vdr-plugin-softhddevice.git#commit=$_gitver"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('SKIP'
+ 'f6ef6cb0bf17c5a28f858e5306776d27')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git describe --tags | sed 's/-/_/g;s/v//'
+}
+
+prepare() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+
+ # Disable OSS. Arch Linux doesn't ship OSS
+ sed -i '/OSS /d' Makefile
+
+ # Enable EOS_TRICKSPEED to fix rewind on 1080i channels
+ sed -i 's/#CONFIG += -DH264_EOS_TRICKSPEED/CONFIG += -DH264_EOS_TRICKSPEED/g' Makefile
+
+ # Enable this to increase AV_INFO logging
+ #sed -i 's/3000/500/g' Makefile
+
+ # Enable this to compile with debug logging
+ #sed -i 's/# -DDEBUG/-DDEBUG/g' Makefile
+
+ # Enable VA-API
+ sed -i 's/#VAAPI/VAAPI/g' Makefile
+ sed -i 's/#OPENGL/OPENGL/g' Makefile
+}
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}