summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:07:40 +0200
committerChristopher Reimer2015-06-08 11:07:40 +0200
commita543a1d658e776d215e4ac65ecbb476adb1585c2 (patch)
tree2fe60866413dc96efdb0246e6675e728baea4482
downloadaur-a543a1d658e776d215e4ac65ecbb476adb1585c2.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO30
-rw-r--r--13_suspendoutput_remove_template_redefine.patch24
-rw-r--r--50-suspendoutput.conf21
-rw-r--r--PKGBUILD53
4 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7991e7a022f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = vdr-suspendoutput
+ pkgdesc = Output device that does nothing
+ pkgver = 2.0.0
+ pkgrel = 9
+ url = http://phivdr.dyndns.org/vdr/vdr-dummydevice/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = ffmpeg
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-suspendoutput.conf
+ source = http://phivdr.dyndns.org/vdr/vdr-suspendoutput/vdr-suspendoutput-2.0.0.tgz
+ source = 10_suspendoutput_vdr-2.1.x_compat.patch::http://www.minidvblinux.de/git/?a=blob&p=vdr-plugin-suspendoutput&h=e9f9bc511668b6d884a000db29b01d970bc5095d
+ source = 11_suspendoutput_svdrp.patch::http://www.minidvblinux.de/git/?a=blob&p=vdr-plugin-suspendoutput&h=045172a810e98bad784cdae4f22bcc305118b490
+ source = 12_suspendoutput_nooutput.patch::http://www.minidvblinux.de/git/?a=blob&p=vdr-plugin-suspendoutput&h=dda561c8a229804b2e9bef05a189be234b95246f
+ source = 13_suspendoutput_remove_template_redefine.patch
+ source = 50-suspendoutput.conf
+ md5sums = 4cbeaf9bf9c83e72ed3a8dee703caf39
+ md5sums = fb094cd51172345fec1d3d30684e6af3
+ md5sums = 4a7dda396e042ab2a5e47c3db06f8925
+ md5sums = 8e3fefbce7410be7c0d960e2eb59d2ce
+ md5sums = f5e5543022910a7eb4f36d888efaf363
+ md5sums = 9b908b272a2f24e1c73b990b53fb5e76
+
+pkgname = vdr-suspendoutput
+
diff --git a/13_suspendoutput_remove_template_redefine.patch b/13_suspendoutput_remove_template_redefine.patch
new file mode 100644
index 000000000000..4e99f98aadf6
--- /dev/null
+++ b/13_suspendoutput_remove_template_redefine.patch
@@ -0,0 +1,24 @@
+--- a/timer.h
++++ b/timer.h
+@@ -242,21 +242,6 @@
+ }
+
+ template<class TCLASS>
+-cTimerEvent *CreateTimerEvent(TCLASS *c, void (TCLASS::*fp)(void),
+- unsigned int TimeoutMs, bool runOnce = true)
+-{
+- return new cTimerFunctor0<TCLASS>(c,fp,TimeoutMs,runOnce);
+-}
+-
+-template<class TCLASS, class TARG1>
+-cTimerEvent *CreateTimerEvent(TCLASS *c, void (TCLASS::*fp)(TARG1),
+- TARG1 arg1,
+- unsigned int TimeoutMs, bool runOnce = true)
+-{
+- return new cTimerFunctor1<TCLASS,TARG1>(c,fp,arg1,TimeoutMs,runOnce);
+-}
+-
+-template<class TCLASS>
+ void CancelTimerEvents(TCLASS *c)
+ {
+ cTimerEvent::CancelAll((void*)c);
diff --git a/50-suspendoutput.conf b/50-suspendoutput.conf
new file mode 100644
index 000000000000..4b890d93f656
--- /dev/null
+++ b/50-suspendoutput.conf
@@ -0,0 +1,21 @@
+[suspendoutput]
+#--menu
+# Show suspend/resume entry in main menu (default)
+
+#--nomenu
+# Don't show entry in main menu
+
+#--timer=MIN
+# Suspend output after MIN minutes of inactivity (default: 120 minutes)
+
+#--notimer
+# Disable inactivity timer
+
+#--paused
+# Allow suspend when replay is paused
+
+#--logo
+# Show VDR logo when suspended
+
+#--blank
+# Blank screen when suspended \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f33f3f29f807
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-suspendoutput
+pkgver=2.0.0
+_vdrapi=2.2.0
+pkgrel=9
+pkgdesc="Output device that does nothing"
+url="http://phivdr.dyndns.org/vdr/vdr-dummydevice/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+makedepends=('ffmpeg')
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://phivdr.dyndns.org/vdr/$pkgname/$pkgname-$pkgver.tgz"
+ "10_suspendoutput_vdr-2.1.x_compat.patch::http://www.minidvblinux.de/git/?a=blob&p=vdr-plugin-suspendoutput&h=e9f9bc511668b6d884a000db29b01d970bc5095d"
+ "11_suspendoutput_svdrp.patch::http://www.minidvblinux.de/git/?a=blob&p=vdr-plugin-suspendoutput&h=045172a810e98bad784cdae4f22bcc305118b490"
+ "12_suspendoutput_nooutput.patch::http://www.minidvblinux.de/git/?a=blob&p=vdr-plugin-suspendoutput&h=dda561c8a229804b2e9bef05a189be234b95246f"
+ '13_suspendoutput_remove_template_redefine.patch'
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('4cbeaf9bf9c83e72ed3a8dee703caf39'
+ 'fb094cd51172345fec1d3d30684e6af3'
+ '4a7dda396e042ab2a5e47c3db06f8925'
+ '8e3fefbce7410be7c0d960e2eb59d2ce'
+ 'f5e5543022910a7eb4f36d888efaf363'
+ '9b908b272a2f24e1c73b990b53fb5e76')
+
+prepare() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ patch -p1 -i "$srcdir/10_suspendoutput_vdr-2.1.x_compat.patch"
+ patch -p1 -i "$srcdir/11_suspendoutput_svdrp.patch"
+ patch -p1 -i "$srcdir/12_suspendoutput_nooutput.patch"
+ patch -p1 -i "$srcdir/13_suspendoutput_remove_template_redefine.patch"
+
+ # http://www.vdr-wiki.de/wiki/index.php/Kategorie:Raspbian_VDR_Streaming_Client_mittels_Streamdev_und_rpihddevice#Installation_vorbereiten
+ for i in *.mpg; do
+ mv $i $i.pes
+ ffmpeg -i $i.pes -f mpegts $i
+ done
+}
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}