summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2016-08-17 18:24:39 +0200
committerChristopher Reimer2016-08-17 18:24:39 +0200
commita232aa08801060d25619b56cfa8e926ac07ee150 (patch)
tree3adba6f817efc51f3fdd2df6520ca22f4bf631a4
parent6aea18999f51a2e8580f9e2b22a2f5006d37cbc5 (diff)
downloadaur-a232aa08801060d25619b56cfa8e926ac07ee150.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/1f46b5b33010c1039c3ca3df4ed8e779f2c04a13)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--tvguideng-fix-compile-error.diff39
3 files changed, 58 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fef72f0a2fba..da2f74f54c34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by makepkg 5.0.1
+# Wed Aug 17 16:24:39 UTC 2016
pkgbase = vdr-tvguideng
pkgdesc = highly customizable 2D EPG viewer plugin.
- pkgver = 0.2.0
- pkgrel = 1
+ pkgver = 0.3.0
+ pkgrel = 2
url = http://projects.vdr-developer.org/projects/plg-tvguideng
arch = x86_64
arch = i686
@@ -12,8 +14,10 @@ pkgbase = vdr-tvguideng
depends = vdr-api=2.2.0
depends = vdr-skindesigner
backup = etc/vdr/conf.avail/50-tvguideng.conf
- source = http://projects.vdr-developer.org/git/vdr-plugin-tvguideng.git/snapshot/vdr-plugin-tvguideng-0.2.0.tar.bz2
- md5sums = e82312ea63e56292f7e88bdae66239ed
+ source = http://projects.vdr-developer.org/git/vdr-plugin-tvguideng.git/snapshot/vdr-plugin-tvguideng-0.3.0.tar.bz2
+ source = tvguideng-fix-compile-error.diff
+ md5sums = dd810a231a1718444d4f02180ae39bb5
+ md5sums = 1c89a7ec96785eb223ec02f2ad4963f5
pkgname = vdr-tvguideng
diff --git a/PKGBUILD b/PKGBUILD
index d7fa4fe4012c..08fd20648792 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,25 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-tvguideng
-pkgver=0.2.0
+pkgver=0.3.0
_vdrapi=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="highly customizable 2D EPG viewer plugin."
url="http://projects.vdr-developer.org/projects/plg-tvguideng"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=("vdr-api=$_vdrapi" 'vdr-skindesigner')
_plugname=${pkgname//vdr-/}
-source=("http://projects.vdr-developer.org/git/vdr-plugin-$_plugname.git/snapshot/vdr-plugin-$_plugname-$pkgver.tar.bz2")
+source=("http://projects.vdr-developer.org/git/vdr-plugin-$_plugname.git/snapshot/vdr-plugin-$_plugname-$pkgver.tar.bz2"
+ 'tvguideng-fix-compile-error.diff')
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-md5sums=('e82312ea63e56292f7e88bdae66239ed')
+md5sums=('dd810a231a1718444d4f02180ae39bb5'
+ '1c89a7ec96785eb223ec02f2ad4963f5')
+
+prepare() {
+ cd "$srcdir/vdr-plugin-$_plugname-$pkgver"
+ patch -p1 -i "$srcdir/tvguideng-fix-compile-error.diff"
+}
build() {
cd "$srcdir/vdr-plugin-$_plugname-$pkgver"
diff --git a/tvguideng-fix-compile-error.diff b/tvguideng-fix-compile-error.diff
new file mode 100644
index 000000000000..a1e803f2acd3
--- /dev/null
+++ b/tvguideng-fix-compile-error.diff
@@ -0,0 +1,39 @@
+diff -ruN vdr-plugin-tvguideng-0.3.0.orig/definitions.h vdr-plugin-tvguideng-0.3.0/definitions.h
+--- vdr-plugin-tvguideng-0.3.0.orig/definitions.h 2016-03-13 16:08:13.000000000 +0100
++++ vdr-plugin-tvguideng-0.3.0/definitions.h 2016-08-15 11:06:22.135609087 +0200
+@@ -234,7 +234,7 @@
+ };
+
+ enum class eDetailedHeaderST {
+- title = eScraperHeaderST::count,
++ title = (int)eScraperHeaderST::count,
+ shorttext,
+ start,
+ stop,
+@@ -249,7 +249,7 @@
+ };
+
+ enum class eDetailedHeaderIT {
+- daynumeric = eScraperHeaderIT::count,
++ daynumeric = (int)eScraperHeaderIT::count,
+ month,
+ year,
+ running,
+@@ -375,7 +375,7 @@
+ };
+
+ enum class eDetailedEpgST {
+- title = eScraperST::count,
++ title = (int)eScraperST::count,
+ shorttext,
+ description,
+ start,
+@@ -393,7 +393,7 @@
+ };
+
+ enum class eDetailedEpgIT {
+- daynumeric = eScraperIT::count,
++ daynumeric = (int)eScraperIT::count,
+ month,
+ year,
+ running,