summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:09:24 +0200
committerChristopher Reimer2015-06-08 11:09:24 +0200
commitb97de2245506a06caa77fef1a95585f31bbc56cf (patch)
tree7c2efb7cd2a883d76965084490656f052fe5ede7
downloadaur-b97de2245506a06caa77fef1a95585f31bbc56cf.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO24
-rw-r--r--50-vnsiserver.conf12
-rw-r--r--PKGBUILD45
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d95c7d643f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vdr-vnsiserver
+ pkgdesc = VDR plugin to handle XBMC clients
+ pkgver = 1.2.1_29_g1772c92
+ pkgrel = 1
+ epoch = 2
+ url = https://github.com/FernetMenta/vdr-plugin-vnsiserver
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-vnsiserver.conf
+ backup = var/lib/vdr/plugins/vnsiserver/allowed_hosts.conf
+ source = git+https://github.com/FernetMenta/vdr-plugin-vnsiserver.git#commit=1772c924e4d803b30eac53c68b4049f35186c108
+ source = 50-vnsiserver.conf
+ md5sums = SKIP
+ md5sums = 833dd896fd81db4a39d2138416b3004d
+
+pkgname = vdr-vnsiserver
+
diff --git a/50-vnsiserver.conf b/50-vnsiserver.conf
new file mode 100644
index 000000000000..131cd9f327ce
--- /dev/null
+++ b/50-vnsiserver.conf
@@ -0,0 +1,12 @@
+[vnsiserver]
+#--device
+# act as the primary device
+
+#--port=n
+# tcp port to listen on
+
+#--test=n
+# TS stream test file to simulate as channel
+
+#--timeout=n
+# stream data timeout in seconds (default: 10)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7ac9428500d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-vnsiserver
+pkgver=1.2.1_29_g1772c92
+_gitver=1772c924e4d803b30eac53c68b4049f35186c108
+_vdrapi=2.2.0
+epoch=2
+pkgrel=1
+url="https://github.com/FernetMenta/vdr-plugin-vnsiserver"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+pkgdesc="VDR plugin to handle XBMC clients"
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+makedepends=('git')
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("git+https://github.com/FernetMenta/vdr-plugin-$_plugname.git#commit=$_gitver"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf"
+ 'var/lib/vdr/plugins/vnsiserver/allowed_hosts.conf')
+md5sums=('SKIP'
+ '833dd896fd81db4a39d2138416b3004d')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-$_plugname"
+ git describe --tags | sed 's/v//;s/-/_/g'
+}
+
+build() {
+ cd "${srcdir}/vdr-plugin-$_plugname"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-$_plugname"
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "$pkgdir/var/lib/vdr/plugins"
+ cp -r vnsiserver "$pkgdir/var/lib/vdr/plugins"
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+
+ chown -R 666:666 "$pkgdir/var/lib/vdr"
+}