summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2016-05-05 16:54:17 +0800
committerGergely Imreh2016-05-05 16:54:17 +0800
commitb71bbaacefbbf066d49c71b34d33ce89db76b19f (patch)
tree3d4fdb5c550b8d514fde7c712ece20bd0a271e41
downloadaur-b71bbaacefbbf066d49c71b34d33ce89db76b19f.tar.gz
create Vectr 0.1.9 release for x86_64
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--vectr.desktop9
-rw-r--r--vectr.svg18
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7f2ae257e55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vectr
+ pkgdesc = Vector graphics design app
+ pkgver = 0.1.9
+ pkgrel = 1
+ url = https://vectr.com/
+ arch = x86_64
+ license = custom
+ source = vectr.desktop
+ source = vectr.svg
+ sha256sums = 7ff45e5176094f9c397a2b917a35ae5c4948e5be0449b07f5df486981cf4174a
+ sha256sums = 0b273cda8c53c94de884efb400ff1d57c75101c966db695f3622f190669e1af9
+ source_x86_64 = http://download.vectr.com/desktop/Vectr-linux-x64-0.1.9.zip
+ sha256sums_x86_64 = 85b1320b8dedf6442ec5599323fe92dde55bccc58cffd75455f287ca4b9a27b6
+
+pkgname = vectr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75eb10224d99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Gergely Imreh <imrehg@gmail.com>
+
+pkgname=vectr
+pkgdesc='Vector graphics design app'
+pkgver=0.1.9
+pkgrel=1
+arch=('x86_64')
+url='https://vectr.com/'
+license=('custom')
+depends=()
+makedepends=()
+source=('vectr.desktop'
+ 'vectr.svg')
+source_x86_64=(http://download.vectr.com/desktop/Vectr-linux-x64-${pkgver}.zip)
+sha256sums=('7ff45e5176094f9c397a2b917a35ae5c4948e5be0449b07f5df486981cf4174a'
+ '0b273cda8c53c94de884efb400ff1d57c75101c966db695f3622f190669e1af9')
+sha256sums_x86_64=('85b1320b8dedf6442ec5599323fe92dde55bccc58cffd75455f287ca4b9a27b6')
+
+package() {
+ if [ "$CARCH" = "x86_64" ]; then
+ _source_arch="x64"
+ fi
+ _source_path="Vectr-linux-${_source_arch}"
+
+ install -d "${pkgdir}/opt"
+
+ cp -R "${srcdir}/${_source_path}" "${pkgdir}/opt/vectr"
+ install -d "$pkgdir"/usr/bin
+ ln -s ../../opt/vectr/Vectr "${pkgdir}/usr/bin/vectr"
+
+ install -Dm644 "${srcdir}/vectr.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ install -Dm644 "${srcdir}/vectr.desktop" "$pkgdir/usr/share/applications/vectr.desktop"
+
+ install -Dm644 "${srcdir}/${_source_path}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/vectr.desktop b/vectr.desktop
new file mode 100644
index 000000000000..3675540e79e7
--- /dev/null
+++ b/vectr.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Vectr
+GenericName=Vector Graphics Design
+Comment=Free Design App For Web + Desktop
+Exec=vectr
+Icon=vectr
+Terminal=false
+Type=Application
+Categories=Graphics;
diff --git a/vectr.svg b/vectr.svg
new file mode 100644
index 000000000000..748a754daa6e
--- /dev/null
+++ b/vectr.svg
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg width="494px" height="168px" viewBox="0 0 494 168" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
+ <title>Vectr Logo</title>
+ <g fill-rule="evenodd">
+ <g transform="translate(116.000000, 19.000000)">
+ <path d="M140.031812,44.5286012 L140.209912,44.4592157 C129.098142,18.325437 103.18914,0 73,0 C32.6832113,0 0,32.6832113 0,73 C0,113.316789 32.6832113,146 73,146 C106.100438,146 134.055422,123.969703 143.002348,93.771714 L143.002348,93.771714 L103.131793,83.8688831 C98.0341921,95.1498772 86.6838438,103 73.5,103 C67.7382491,103 62.3266889,101.500656 57.6342003,98.8708485 L140.12529,44.6005793 L140.031812,44.5286012 Z M88.8060525,41.8226494 C84.2449893,39.3831657 79.0340226,38 73.5,38 C55.5507447,38 41,52.5507447 41,70.5 C41,72.9775802 41.2772348,75.3904087 41.8023749,77.7091559 L88.8060525,41.8226494 Z"></path>
+ </g>
+ <g id="C" transform="translate(233.000000, 19.000000)">
+ <path d="M133.396886,114.015381 C120.261064,133.320905 98.1112134,146 73,146 C32.6832113,146 0,113.316789 0,73 C0,32.6832113 32.6832113,0 73,0 C93.9623565,0 112.861061,8.83553925 126.175131,22.9856351 L94.7123253,48.8763735 C89.0196239,43.9678995 81.6064072,41 73.5,41 C55.5507447,41 41,55.5507447 41,73.5 C41,91.4492553 55.5507447,106 73.5,106 C83.6468242,106 92.7075828,101.350004 98.6675639,94.0647226 L133.396886,114.015381 Z"></path>
+ </g>
+ <path d="M352.155073,10.467194 L352.155073,34.5630918 L338,34.5630918 L338,72.3761316 L350.941154,72.3761316 L350.941154,140.623544 C350.941154,140.623544 350.941154,157.6634 373.146049,162.999993 C395.350944,168.336587 410.263626,164 410.263626,164 L410.263626,125.247077 L400.074728,123.247077 L400.074728,73.4768379 L414,73.4768379 L414,35.1138608 L399.533502,35.1138608 L398.769495,-1.11022302e-16 L352.155073,10.467194 Z"></path>
+ <g id="V" transform="translate(0.000000, 1.000000)">
+ <path d="M-0.43373844,0.263228416 L45.4077113,0.263228416 L73.1895711,72.4870123 L84,72.4870123 L60.4227565,127.56594 L47.9622195,127.56594 L-0.43373844,0.263228416 Z"></path>
+ <path d="M167,1 L121.941876,1 L60.304831,145.609451 L52.9769034,145.609451 L60.3048312,164 L94.4663697,164 L167,1 Z"></path>
+ </g>
+ <path d="M469.113634,72.5649316 C477.118957,65.7438416 492.218172,63.005369 492.218172,63.005369 L492.218172,20.0603077 C492.218172,20.0603077 482.643153,20.0794125 473.548495,22.7566974 C464.453836,25.4339816 455.639732,30.8282669 455.639732,30.8282669 L455.639732,19.3392334 L414,30.7594109 L414,164.839233 L457.186087,164.839233 L457.186087,103.586584 C457.186087,90.586584 461.108311,79.3860219 469.113634,72.5649316 Z"></path>
+ </g>
+</svg>