summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-06-05 20:43:11 +0200
committerFabioLolix2022-06-05 20:43:11 +0200
commit1adafd01ffa9cd8e922a73ef232fde76206e3339 (patch)
treefd083a790bc310952749cc8925d4208cf47dc100
downloadaur-1adafd01ffa9cd8e922a73ef232fde76206e3339.tar.gz
upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3dc75ed789ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vegastrike
+ pkgdesc = Vega Strike - Upon the Coldest Sea. Space flight and trading simulator with realistic distances
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://www.vega-strike.org/
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = vegastrike-engine
+ options = !strip
+ source = git+https://github.com/vegastrike/Assets-Production#tag=v0.8.0
+ sha256sums = SKIP
+
+pkgname = vegastrike
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83d98f60abe6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Evert Vorster <evorster@gmail.com>
+
+pkgname=vegastrike
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Vega Strike - Upon the Coldest Sea. Space flight and trading simulator with realistic distances"
+arch=(any)
+url="https://www.vega-strike.org/"
+license=(GPL2)
+depends=(vegastrike-engine)
+makedepends=(git cmake)
+options=(!strip)
+source=("git+https://github.com/vegastrike/Assets-Production#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build(){
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "${srcdir}"/Assets-Production/CMakeLists.txt
+}
+
+package() {
+ make -C "${srcdir}" DESTDIR="${pkgdir}" install
+}
+