summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2020-07-12 13:09:54 +0200
committerevorster2020-07-12 13:09:54 +0200
commitb82d66d471ac65f46951c3b23470535a268416db (patch)
tree941f90637cedd7c4e3d303caa2b8f3dd26e819a6
parent48f01ab76b0158ca2934fd7715d429f77c19ef40 (diff)
downloadaur-b82d66d471ac65f46951c3b23470535a268416db.tar.gz
Install targets finally in master
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
-rw-r--r--mesh_tool_install.patch8
3 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbd755e12618..38c86919cee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vegastrike-engine-git
pkgdesc = A spaceflight simulator in massive universe
- pkgver = rev.13951
+ pkgver = rev.13954
pkgrel = 1
url = www.vega-strike.org
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index babe3fb1ad18..9bccec540d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Evert Vorster <evorster@gmail.com>
pkgname=vegastrike-engine-git
-pkgver=rev.13951
+pkgver=rev.13954
pkgrel=1
pkgdesc="A spaceflight simulator in massive universe"
arch=('i686' 'x86_64')
@@ -31,7 +31,7 @@ cd ..
pwd
mkdir -p build
-patch -Np1 -i ../mesh_tool_install.patch
+#patch -Np1 -i ../mesh_tool_install.patch
}
build(){
@@ -45,8 +45,11 @@ build(){
}
package() {
-mkdir -p "${pkgdir}"/usr/bin
- cd build
- cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
-#make -C build DESTDIR="${pkgdir}" install
+#Hopefully we are done horsing around with this now.
+#mkdir -p "${pkgdir}"/usr/bin
+# cd build
+# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+#
+#This should be the only way to install
+make -C build DESTDIR="${pkgdir}" install
}
diff --git a/mesh_tool_install.patch b/mesh_tool_install.patch
deleted file mode 100644
index bf8c178408c1..000000000000
--- a/mesh_tool_install.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/objconv/CMakeLists.txt.orig 2020-06-17 09:32:16.811021115 +0200
-+++ src/Vega-Strike-Engine-Source/engine/objconv/CMakeLists.txt 2020-06-17 09:40:23.923412625 +0200
-@@ -59,3 +59,5 @@
- ENDIF (OGRE_FOUND AND NOT USE_SYSTEM_BOOST)
-
- TARGET_LINK_LIBRARIES(mesh_tool ${MSH_LIBS})
-+
-+INSTALL(TARGETS mesh_tool DESTINATION bin)