summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2020-07-28 07:32:59 +0200
committerevorster2020-07-28 07:32:59 +0200
commit3167415e15ad45eaa2dade0da06aa94438905bcf (patch)
tree4932a4991e36fa4726655327c9238c8f46f25bc9
parentecec0d5f4b10783f910903026c4b1d59a82acce8 (diff)
downloadaur-3167415e15ad45eaa2dade0da06aa94438905bcf.tar.gz
Release updates
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ca37a8200e8..aac781e1b62f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vegastrike-engine-release-git
pkgdesc = A spaceflight simulator in massive universe
- pkgver = rev.13856
+ pkgver = rev.13874
pkgrel = 1
url = www.vega-strike.org
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 003e08ee0add..582fb3fdb671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Evert Vorster <evorster@gmail.com>
pkgname=vegastrike-engine-release-git
-pkgver=rev.13856
+pkgver=rev.13874
pkgrel=1
pkgdesc="A spaceflight simulator in massive universe"
arch=('i686' 'x86_64')
@@ -23,10 +23,19 @@ pkgver() {
}
prepare(){
+#PR patches here.
+cd "${srcdir}"/Vega-Strike-Engine-Source
+#patch -Np1 -i ../../install.patch
+
+cd ..
+#personal patches
mkdir -p build
#for now, these two patches modify the same line in CMakelists.txt
#patch -Np1 -i ../py2.patch
patch -Np1 -i ../Python.patch
+#patch -Np1 -i ../galaxy.patch
+#patch -Np1 -i ../nav.patch
+#patch -Np1 -i ../nav_galaxy.patch
}
build(){
@@ -41,8 +50,9 @@ build(){
}
package() {
-mkdir -p "${pkgdir}"/usr/bin
- cd build
- mv -vf setup/vssetup setup/vegasettings
- cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+#mkdir -p "${pkgdir}"/usr/bin
+# cd build
+# mv -vf setup/vssetup setup/vegasettings
+# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+make -C build DESTDIR="${pkgdir}" install
}