summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2020-06-19 12:02:59 +0200
committerevorster2020-06-19 12:02:59 +0200
commitd3bfdfa661a2e5e8524d253cae982d97d92025e3 (patch)
tree51d13acfab6445a94d112474f5f204c2acf46608
downloadaur-d3bfdfa661a2e5e8524d253cae982d97d92025e3.tar.gz
first successful build
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD45
-rw-r--r--py2.patch11
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..815d0c76610e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vegastrike-engine-release-git
+ pkgdesc = A spaceflight simulator in massive universe
+ pkgver = rev.13847
+ pkgrel = 1
+ url = www.vega-strike.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = boost-libs
+ depends = python
+ depends = freeglut
+ depends = gtk2
+ depends = openal
+ depends = sdl
+ depends = glu
+ provides = vegastrike-engine
+ conflicts = vegastrike-engine
+ source = git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.6.x
+ sha1sums = SKIP
+
+pkgname = vegastrike-engine-release-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cce5805ae2bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+#Maintainer: Evert Vorster <evorster@gmail.com>
+pkgname=vegastrike-engine-release-git
+pkgver=rev.13847
+pkgrel=1
+pkgdesc="A spaceflight simulator in massive universe"
+arch=('i686' 'x86_64')
+url="www.vega-strike.org"
+license=('GPL')
+depends=('boost-libs' 'python' 'freeglut' 'gtk2' 'openal' 'sdl' 'glu')
+#optdepends=('vegastrike-data: original dataset')
+makedepends=('git' 'cmake')
+provides=('vegastrike-engine')
+conflicts=('vegastrike-engine')
+#install=$pkgname.install
+#options=(!makeflags debug !strip)
+
+source=('git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.6.x')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/Vega-Strike-Engine-Source
+ echo "rev.$(git rev-list --count HEAD)"
+}
+
+prepare(){
+mkdir -p build
+patch -Np1 -i ../py2.patch
+}
+
+build(){
+ cd build
+ cmake ../Vega-Strike-Engine-Source/engine/ \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_PIE=ON \
+ -DUSE_PYTHON_3=OFF
+ make
+}
+
+package() {
+mkdir -p "${pkgdir}"/usr/bin
+ cd build
+ mv -vf setup/vssetup setup/vegasettings
+ cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+}
diff --git a/py2.patch b/py2.patch
new file mode 100644
index 000000000000..a54093fb8ac6
--- /dev/null
+++ b/py2.patch
@@ -0,0 +1,11 @@
+--- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt.orig 2020-06-19 11:03:05.414334071 +0200
++++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-19 11:31:45.046587335 +0200
+@@ -788,7 +788,7 @@
+ # Find Boost with boost_python library
+ OPTION(USE_SYSTEM_BOOST "Use system boost" OFF)
+ IF (USE_SYSTEM_BOOST)
+- FIND_PACKAGE(Boost COMPONENTS python)
++ FIND_PACKAGE(Boost COMPONENTS python27)
+ IF (Boost_FOUND)
+ MESSAGE("++ Found System Boost : ${Boost_VERSION}")
+ SET(BOOST_PYTHON_NO_PY_SIGNATURES 1)