summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2020-06-17 18:27:02 +0200
committerevorster2020-06-17 18:27:02 +0200
commit8ea17f6657aa00dbeadd38aaf9cedb72cd10647f (patch)
treedb2bd3cac813ec9d198c6342b1cd1cf24c697b92
parent31d465a9c3f1ee60e43723ac2357ee53aeb0f5e2 (diff)
downloadaur-8ea17f6657aa00dbeadd38aaf9cedb72cd10647f.tar.gz
wiped out the engine, this package now provides the data
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD58
-rw-r--r--mesh_tool_install.patch8
-rw-r--r--python3_compile.patch11
-rw-r--r--vegasettings_install.patch11
-rw-r--r--vegastrike_install.patch11
6 files changed, 36 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0924ad32dcfe..6b000efeb196 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,18 @@
pkgbase = vegastrike-git
- pkgdesc = A spaceflight simulator in massive universe
- pkgver = rev.13926
+ pkgdesc = A spaceflight simulator in massive universe-data files
+ pkgver = rev.11354
pkgrel = 1
url = www.vega-strike.org
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
makedepends = git
makedepends = cmake
- depends = boost-libs
- depends = python
- depends = freeglut
- depends = gtk2
- depends = libvorbis
- depends = openal
- depends = sdl
- depends = glu
- depends = vegastrike-data
+ depends = expat
+ depends = vegastrike-engine
+ optdepends =
provides = vegastrike
conflicts = vegastrike
- source = git+https://github.com/vegastrike/Vega-Strike-Engine-Source
+ source = git+https://github.com/vegastrike/Assets-Production
sha1sums = SKIP
pkgname = vegastrike-git
diff --git a/PKGBUILD b/PKGBUILD
index e9055a764549..edb584ea1314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,49 @@
#Maintainer: Evert Vorster <evorster@gmail.com>
pkgname=vegastrike-git
-pkgver=rev.13926
+_pkgname=vegastrike
+pkgver=rev.11354
pkgrel=1
-pkgdesc="A spaceflight simulator in massive universe"
-arch=('i686' 'x86_64')
+pkgdesc="A spaceflight simulator in massive universe-data files"
+arch=('any')
url="www.vega-strike.org"
license=('GPL')
-depends=('boost-libs' 'python' 'freeglut' 'gtk2' 'libvorbis' 'openal' 'sdl' 'glu' 'vegastrike-data')
-#optdepends=('vegastrike-data: original dataset')
+depends=('expat' 'vegastrike-engine')
+optdepends=('')
makedepends=('git' 'cmake')
provides=('vegastrike')
conflicts=('vegastrike')
#install=$pkgname.install
#options=(!makeflags debug !strip)
-source=('git+https://github.com/vegastrike/Vega-Strike-Engine-Source')
+source=('git+https://github.com/vegastrike/Assets-Production')
sha1sums=('SKIP')
pkgver() {
- cd "${srcdir}"/Vega-Strike-Engine-Source
+ cd "${srcdir}"/Assets-Production
echo "rev.$(git rev-list --count HEAD)"
}
-prepare(){
-mkdir -p build
-patch -Np1 -i ../python3_compile.patch
-patch -Np1 -i ../vegastrike_install.patch
-patch -Np1 -i ../vegasettings_install.patch
-patch -Np1 -i ../mesh_tool_install.patch
-}
+package() {
+ cd "${srcdir}"
-build(){
-export DATA_DIR=/usr/share/vegastrike
- cd build
- cmake ../Vega-Strike-Engine-Source/engine/ \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_PIE=ON \
- -DUSE_PYTHON_3=ON
- make
-}
+#data files install
+ install -d "${pkgdir}"/usr/share
+ cp -a "${srcdir}"/Assets-Production/ "${pkgdir}"/usr/share/${_pkgname}/
+#remove some extra files
+cd "${pkgdir}"/usr/share/${_pkgname}/
+rm -rf .git
+rm -rf .github
+rm -rf .gitignore
+
+# mv "${pkgdir}"/usr/share/data "${pkgdir}"/usr/share/${_pkgname}
+
+#install man page, .desktop file and icon
+# install -D -m644 "${pkgdir}"/usr/share/${_pkgname}/documentation/${_pkgname}.1 \
+# "${pkgdir}"/usr/share/man/man1/${_pkgname}.1
+
+ install -D -m644 "${pkgdir}"/usr/share/${_pkgname}/${_pkgname}.desktop \
+ "${pkgdir}"/usr/share/applications/${_pkgname}.desktop
+ install -D -m644 "${pkgdir}"/usr/share/${_pkgname}/${_pkgname}.xpm \
+ "${pkgdir}"/usr/share/pixmaps/${_pkgname}.xpm
-package() {
-#mkdir -p "${pkgdir}"/usr/bin
-# cd build
-# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
-make -C build DESTDIR="${pkgdir}" install
}
diff --git a/mesh_tool_install.patch b/mesh_tool_install.patch
deleted file mode 100644
index bf8c178408c1..000000000000
--- a/mesh_tool_install.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/objconv/CMakeLists.txt.orig 2020-06-17 09:32:16.811021115 +0200
-+++ src/Vega-Strike-Engine-Source/engine/objconv/CMakeLists.txt 2020-06-17 09:40:23.923412625 +0200
-@@ -59,3 +59,5 @@
- ENDIF (OGRE_FOUND AND NOT USE_SYSTEM_BOOST)
-
- TARGET_LINK_LIBRARIES(mesh_tool ${MSH_LIBS})
-+
-+INSTALL(TARGETS mesh_tool DESTINATION bin)
diff --git a/python3_compile.patch b/python3_compile.patch
deleted file mode 100644
index 7ddf30236c7e..000000000000
--- a/python3_compile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt_backup 2020-06-15 18:54:51.819058797 +0200
-+++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-15 18:55:43.456681085 +0200
-@@ -720,7 +720,7 @@
- UNSET(Boost_python_FOUND CACHE)
- IF (USE_PYTHON_3)
- MESSAGE("++ Looking for System Boost::python3")
-- FIND_PACKAGE(Boost COMPONENTS python3 log log_setup REQUIRED)
-+ FIND_PACKAGE(Boost COMPONENTS python log log_setup REQUIRED)
- ELSE (USE_PYTHON_3)
- MESSAGE("++ Looking for System Boost::python (py2)")
- FIND_PACKAGE(Boost COMPONENTS python log log_setup REQUIRED)
diff --git a/vegasettings_install.patch b/vegasettings_install.patch
deleted file mode 100644
index 502808ffacec..000000000000
--- a/vegasettings_install.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/setup/CMakeLists.txt.orig 2020-06-17 09:28:36.348748984 +0200
-+++ src/Vega-Strike-Engine-Source/engine/setup/CMakeLists.txt 2020-06-17 09:41:47.556144351 +0200
-@@ -12,6 +12,8 @@
-
- ADD_EXECUTABLE(vegasettings ${VEGASETTINGS_SOURCES})
-
-+ INSTALL(TARGETS vegasettings DESTINATION bin)
-+
- #find GTK2
- FIND_PACKAGE(GTK2 REQUIRED)
- IF (GTK2_FOUND)
diff --git a/vegastrike_install.patch b/vegastrike_install.patch
deleted file mode 100644
index acf6da002ead..000000000000
--- a/vegastrike_install.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt.orig 2020-06-17 08:18:19.562336282 +0200
-+++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-17 08:20:30.666476756 +0200
-@@ -1070,6 +1070,8 @@
- vorbisfile_LIBRARY
- )
-
-+INSTALL(TARGETS vegastrike DESTINATION bin)
-+
- SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "3D OpenGL spaceflight simulator")
- SET(CPACK_PACKAGE_VENDOR "Vega Strike")
- SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}/../README.md")