summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Cocora2018-12-08 11:34:50 +0000
committerStefan Cocora2018-12-08 11:34:50 +0000
commitc4196a30963d2e292093fa8220d9740f122ca3c7 (patch)
tree82d9022fb6370c6204f7ed609de09e8c44563d42
downloadaur-c4196a30963d2e292093fa8220d9740f122ca3c7.tar.gz
[feature] Initial AUR build of the vegeta load testing tool
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66ba460f9b15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vegeta-bin
+ pkgdesc = Vegeta is a versatile HTTP load testing tool built out of a need to drill HTTP services with a constant request rate. It can be used both as a command line utility and a library.
+ pkgver = 12.0.0
+ pkgrel = 1
+ url = https://github.com/tsenart/vegeta
+ arch = x86_64
+ license = MIT
+ source = vegeta-12.0.0-linux-amd64.tar.gz::https://github.com/tsenart/vegeta/releases/download/cli/v12.0.0/vegeta-12.0.0-linux-amd64.tar.gz
+ source = LICENSE::https://raw.githubusercontent.com/tsenart/vegeta/master/LICENSE
+ sha256sums = 05243352c79950764fc837cd3cd4f2fd87892fbfe24465c87c390bc04530bca5
+ sha256sums = 374db7067e9e238a74a5c3d25d9f17d5a6fb885e4b6392897ceffcabb274fd7c
+
+pkgname = vegeta-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3a7b223dd7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Stefan Cocora <stefan dot cocora at gmail dot com>
+# Contributor:
+
+_pkgauthor=tsenart
+_upstream_pkgname=vegeta
+pkgname=vegeta-bin
+pkgver=12.0.0
+pkgrel=1
+pkgdesc="Vegeta is a versatile HTTP load testing tool built out of a need to drill HTTP services with a constant request rate. It can be used both as a command line utility and a library."
+arch=('x86_64')
+_goos="linux"
+_goarch="amd64"
+groups=()
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+url="https://github.com/${_pkgauthor}/${_upstream_pkgname}"
+license=("MIT")
+# https://github.com/tsenart/vegeta/releases/download/v12.0.0/vegeta-linux-amd64.tar.gz
+# https://github.com/tsenart/vegeta/releases/download/cli/v12.1.0/vegeta-12.1.0-linux-amd64.tar.gz
+source=("${_upstream_pkgname}-${pkgver}-${_goos}-${_goarch}.tar.gz::https://github.com/${_pkgauthor}/${_upstream_pkgname}/releases/download/cli/v${pkgver}/${_upstream_pkgname}-${pkgver}-${_goos}-${_goarch}.tar.gz"
+ "LICENSE::https://raw.githubusercontent.com/${_pkgauthor}/${_upstream_pkgname}/master/LICENSE")
+sha256sums=(
+ "05243352c79950764fc837cd3cd4f2fd87892fbfe24465c87c390bc04530bca5"
+ "374db7067e9e238a74a5c3d25d9f17d5a6fb885e4b6392897ceffcabb274fd7c"
+)
+
+package() {
+
+ install -Dm755 "${srcdir}/${_upstream_pkgname}" "${pkgdir}/usr/bin/${_upstream_pkgname}"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_upstream_pkgname}/LICENSE"
+}