summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorl0gic2023-09-12 01:05:47 +0200
committerl0gic2023-09-12 01:05:47 +0200
commit1ab88de09596d1f636f259981d35a5b67ead5305 (patch)
tree76cf75ef6cee5693d488c881b9f01fdd20bc7573
parent256a14792673a96d8e6746bf4cfba4282373184c (diff)
downloadaur-1ab88de09596d1f636f259981d35a5b67ead5305.tar.gz
Add missing veilid user/group
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD27
-rw-r--r--veilid.sysusers1
3 files changed, 30 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e5f0819733..5e6bfae73de3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = veilid-git
pkgdesc = Veilid headless node
- pkgver = 0.1.10.r49.g2ab51ae
+ pkgver = 0.2.1.r46.g797e34f
pkgrel = 1
url = https://veilid.com
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = veilid-git
makedepends = cargo
makedepends = capnproto
makedepends = protobuf
- provides = veilid=0.1.10
+ provides = veilid=0.2.1
conflicts = veilid
source = git+https://gitlab.com/veilid/veilid.git
source = git+https://gitlab.com/veilid/cursive.git
@@ -21,15 +21,17 @@ pkgbase = veilid-git
source = git+https://gitlab.com/veilid/mdns.git
source = git+https://gitlab.com/veilid/hashlink.git
source = git+https://gitlab.com/veilid/rust-igd.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = veilid.sysusers
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 2ce72c2aa7799f39d1b6dca3173b12943c551dad615cf4ec21cc03e10890c8e1
pkgname = veilid-git
diff --git a/PKGBUILD b/PKGBUILD
index 12a8f32b2e53..3b3280fd6df8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_pkgname="veilid"
pkgname="${_pkgname}-git"
-pkgver=0.1.10.r49.g2ab51ae
+pkgver=0.2.1.r46.g797e34f
pkgrel=1
pkgdesc="Veilid headless node"
arch=('x86_64')
@@ -20,18 +20,20 @@ source=("git+https://gitlab.com/${_pkgname}/${_pkgname}.git"
"git+https://gitlab.com/${_pkgname}/libmdns.git"
"git+https://gitlab.com/${_pkgname}/mdns.git"
"git+https://gitlab.com/${_pkgname}/hashlink.git"
- "git+https://gitlab.com/${_pkgname}/rust-igd.git")
+ "git+https://gitlab.com/${_pkgname}/rust-igd.git"
+ "veilid.sysusers")
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '2ce72c2aa7799f39d1b6dca3173b12943c551dad615cf4ec21cc03e10890c8e1')
prepare() {
export RUSTUP_TOOLCHAIN=stable
@@ -80,4 +82,5 @@ package() {
install -Dm0755 -t "${pkgdir}/usr/bin/" "target/release/${_pkgname}-server"
install -Dm0755 -t "${pkgdir}/usr/bin/" "target/release/${_pkgname}-cli"
install -Dm0644 -t "${pkgdir}/usr/lib/systemd/system/" "package/systemd/${_pkgname}-server.service"
+ install -Dm0644 "${srcdir}/${_pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_pkgname}.conf"
}
diff --git a/veilid.sysusers b/veilid.sysusers
new file mode 100644
index 000000000000..cac9486d1495
--- /dev/null
+++ b/veilid.sysusers
@@ -0,0 +1 @@
+u veilid - - -