summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-10-21 21:34:45 -0300
committerFilipe Nascimento2020-10-21 21:34:45 -0300
commit44cf26bd2ffd108cd856d7f76a2ed40c21bec858 (patch)
tree899c866eb600d23611e0ec5666f0151202fde185
parent6118770927039bad3eae20d47fbe5608616cee13 (diff)
downloadaur-44cf26bd2ffd108cd856d7f76a2ed40c21bec858.tar.gz
upgpkg: velero 1.5.2-2
make sure VERSION var is passed to Make and remove unnecessary optdepends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa7f866103c6..53add92a1550 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = velero
pkgdesc = Backup and migrate Kubernetes applications and their persistent volumes
pkgver = 1.5.2
- pkgrel = 1
+ pkgrel = 2
url = https://velero.io
arch = x86_64
arch = armv6h
@@ -12,7 +12,6 @@ pkgbase = velero
makedepends = go
depends = glibc
depends = kubectl
- optdepends = restic: for restic integration support
source = git+https://github.com/vmware-tanzu/velero#tag=v1.5.2
source = build.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6ac91b31307a..a1e13ecad81b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
pkgname=velero
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="Backup and migrate Kubernetes applications and their persistent volumes"
arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://velero.io"
license=('Apache')
depends=('glibc' 'kubectl')
makedepends=('git' 'go')
-optdepends=('restic: for restic integration support')
source=("git+https://github.com/vmware-tanzu/velero#tag=v$pkgver"
"build.patch")
sha256sums=('SKIP'
@@ -31,7 +30,7 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
export GOLDFLAGS="-linkmode=external"
- make local GIT_TREE_STATE=clean
+ make local GIT_TREE_STATE=clean VERSION=$pkgver
./velero completion bash | install -Dm644 /dev/stdin share/bash-completion/completions/velero
./velero completion zsh | install -Dm644 /dev/stdin share/zsh/site-functions/_velero