summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-09-27 14:15:58 -0300
committerFilipe Nascimento2020-09-27 14:20:08 -0300
commit6dd3d082e187c190f6e3453904de09a482c6173f (patch)
tree880daebace5f3bafccd85c9083c31e9e7357c32c
downloadaur-6dd3d082e187c190f6e3453904de09a482c6173f.tar.gz
Initial upload: velero 1.5.1-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a13f9619d8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = velero
+ pkgdesc = Backup and migrate Kubernetes applications and their persistent volumes
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://velero.io
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = go
+ depends = kubectl
+ optdepends = restic: for restic integration support
+ source = velero-1.5.1.tar.gz::https://github.com/vmware-tanzu/velero/archive/v1.5.1.tar.gz
+ sha256sums = b5d8f50f8f84f08ec7fc72d2572fd15749b3b95f1a0ac2483f3a4fe6f43e4961
+
+pkgname = velero
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c53fbbf69fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Filipe Nascimento <flipee at tuta dot io>
+
+pkgname=velero
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="Backup and migrate Kubernetes applications and their persistent volumes"
+arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://velero.io"
+license=('Apache')
+depends=('kubectl')
+makedepends=('go')
+optdepends=('restic: for restic integration support')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vmware-tanzu/velero/archive/v$pkgver.tar.gz")
+sha256sums=('b5d8f50f8f84f08ec7fc72d2572fd15749b3b95f1a0ac2483f3a4fe6f43e4961')
+
+build() {
+ cd $pkgname-$pkgver
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+
+ _commit=87d86a45a6ca66c6c942c7c7f08352e26809426c
+
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode=external
+ -X \"github.com/vmware-tanzu/velero/pkg/buildinfo.Version=$pkgver\"
+ -X \"github.com/vmware-tanzu/velero/pkg/buildinfo.GitSHA=$_commit\"
+ -X \"github.com/vmware-tanzu/velero/pkg/buildinfo.GitTreeState=clean\"" \
+ -o $pkgname cmd/velero/main.go
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname -t "$pkgdir/usr/bin"
+ $pkgname completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ $pkgname completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+}