summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2021-04-13 16:03:03 -0300
committerFilipe Nascimento2021-04-13 16:03:03 -0300
commitab4cce15d959a0d31faf4f5f31929112fc8f01fe (patch)
tree024a21cef697cf48cf3b02ff6387fd25bfc0ada8
parentde524693855344f3e59e833fc284729a446bb6dd (diff)
downloadaur-ab4cce15d959a0d31faf4f5f31929112fc8f01fe.tar.gz
upgpkg: velero 1.6.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--build.patch19
3 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea4949223f06..9148eb19608a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = velero
pkgdesc = Backup and migrate Kubernetes applications and their persistent volumes
- pkgver = 1.5.3
+ pkgver = 1.6.0
pkgrel = 1
url = https://velero.io
arch = x86_64
@@ -12,10 +12,10 @@ pkgbase = velero
makedepends = go
depends = glibc
depends = kubectl
- source = git+https://github.com/vmware-tanzu/velero#tag=v1.5.3
+ source = git+https://github.com/vmware-tanzu/velero#tag=v1.6.0
source = build.patch
sha256sums = SKIP
- sha256sums = 6a3a98867f35180ed604da9fa608c290107651b5ebba9409bcedd45c395cdda4
+ sha256sums = 4b71ee9fcf3f272a1bd88e100119ea6c031a732c6a01ed81235ad7eceb63a63b
pkgname = velero
diff --git a/PKGBUILD b/PKGBUILD
index 562b66a2b9e3..49aa613d0ce4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=velero
-pkgver=1.5.3
+pkgver=1.6.0
pkgrel=1
pkgdesc="Backup and migrate Kubernetes applications and their persistent volumes"
arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -12,7 +12,7 @@ makedepends=('git' 'go')
source=("git+https://github.com/vmware-tanzu/velero#tag=v$pkgver"
"build.patch")
sha256sums=('SKIP'
- '6a3a98867f35180ed604da9fa608c290107651b5ebba9409bcedd45c395cdda4')
+ '4b71ee9fcf3f272a1bd88e100119ea6c031a732c6a01ed81235ad7eceb63a63b')
prepare() {
cd $pkgname
diff --git a/build.patch b/build.patch
index 31e1547027f1..def0fd742f08 100644
--- a/build.patch
+++ b/build.patch
@@ -1,9 +1,9 @@
diff --git a/hack/build.sh b/hack/build.sh
-index b04378ad..d6f320d1 100755
+index d5492887..e78ac8d3 100755
--- a/hack/build.sh
+++ b/hack/build.sh
-@@ -51,22 +51,13 @@ if [[ -z "${GIT_TREE_STATE}" ]]; then
- exit 1
+@@ -56,9 +56,9 @@ if [[ ${DEBUG:-} = "1" ]]; then
+ GCFLAGS="all=-N -l"
fi
-export CGO_ENABLED=0
@@ -14,17 +14,10 @@ index b04378ad..d6f320d1 100755
LDFLAGS="${LDFLAGS} -X ${PKG}/pkg/buildinfo.GitSHA=${GIT_SHA}"
LDFLAGS="${LDFLAGS} -X ${PKG}/pkg/buildinfo.GitTreeState=${GIT_TREE_STATE}"
--if [[ -z "${OUTPUT_DIR:-}" ]]; then
-- OUTPUT_DIR=.
--fi
--OUTPUT=${OUTPUT_DIR}/${BIN}
--if [[ "${GOOS}" = "windows" ]]; then
-- OUTPUT="${OUTPUT}.exe"
--fi
--
+@@ -73,6 +73,5 @@ fi
go build \
-- -o ${OUTPUT} \
+ -o ${OUTPUT} \
+ -gcflags "${GCFLAGS}" \
- -installsuffix "static" \
-+ -o ${OUTPUT_DIR} \
-ldflags "${LDFLAGS}" \
${PKG}/cmd/${BIN}