summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans-Willem Hardijzer2017-10-29 18:46:16 +0100
committerFrans-Willem Hardijzer2017-10-29 18:46:16 +0100
commit384700dfc4aae3dac1ac929b866587051dd57161 (patch)
tree435db6ae4ab8f76dea1b6796045477689113547d
downloadaur-384700dfc4aae3dac1ac929b866587051dd57161.tar.gz
First attempt at Velocidrone PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--velocidrone-1.11.0.299.zip.sha2561
-rw-r--r--velocidrone.desktop11
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb8fac3e879c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = velocidrone
+ pkgdesc = Velocidrone: Fast paced FPV drone racing action with multiplayer and offline modes!
+ pkgver = 1.11.0.299
+ pkgrel = 1
+ url = http://www.velocidrone.com/
+ arch = x86_64
+ license = proprietary
+ makedepends = wget
+ makedepends = unzip
+ depends = gcc-libs
+ depends = gtk2
+ optdepends = steam
+ source = file://velocidrone-1.11.0.299.zip.sha256
+ source = file://velocidrone.desktop
+ source = https://www.velocidrone.com/img/logo.png
+ sha256sums = ab5b2b30717ecd35219eac63cf9140bfe1e56b1da04cf7785ccb0f7dff4e6483
+ sha256sums = 66ab24798d6b40f2c69f42368b79205f1e39ace4d8880785bfeb47f7f20d98cb
+ sha256sums = dca386606781e552fc310bf414a911b335bb8d48114091f337d02db46befdee1
+
+pkgname = velocidrone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2a379e2381c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Frans-Willem Hardijzer <fw@hardijzer.nl>
+
+pkgname=velocidrone
+pkgver=1.11.0.299
+pkgrel=1
+pkgdesc="Velocidrone: Fast paced FPV drone racing action with multiplayer and offline modes!"
+arch=('x86_64')
+url="http://www.velocidrone.com/"
+license=('proprietary')
+makedepends=(wget unzip)
+depends=(gcc-libs gtk2)
+optdepends=(steam)
+conflicts=()
+_source_id="0B5ZmVufmkjnwQU5jTVZ4TFJIZGs"
+source=(
+ "file://velocidrone-$pkgver.zip.sha256"
+ "file://velocidrone.desktop"
+ "https://www.velocidrone.com/img/logo.png")
+sha256sums=('ab5b2b30717ecd35219eac63cf9140bfe1e56b1da04cf7785ccb0f7dff4e6483'
+ '66ab24798d6b40f2c69f42368b79205f1e39ace4d8880785bfeb47f7f20d98cb'
+ 'dca386606781e552fc310bf414a911b335bb8d48114091f337d02db46befdee1')
+prepare() {
+ wget "https://drive.google.com/uc?export=download&id=$_source_id" -O avcheck.html --save-cookie cookie.txt
+ _confirm=$(grep -e "confirm=[^'\"&]\+" -o avcheck.html)
+ wget -c "https://drive.google.com/uc?export=download&id=$_source_id&$_confirm" --load-cookie cookie.txt -O velocidrone-$pkgver.zip
+ echo Checking downloaded file checksum
+ sha256sum --strict -c velocidrone-$pkgver.zip.sha256
+}
+package() {
+ mkdir -p "$pkgdir/opt/velocidrone/"
+ unzip "$srcdir/velocidrone-$pkgver.zip" -d "$pkgdir/opt/velocidrone/"
+ chmod ugo+x "$pkgdir/opt/velocidrone/velocidrone.x86_64"
+ install -Dm644 "$srcdir/velocidrone.desktop" "${pkgdir}/usr/share/applications/$pkgname.desktop"
+ install -Dm 644 "$srcdir/logo.png" "${pkgdir}/opt/velocidrone/icon.png"
+}
diff --git a/velocidrone-1.11.0.299.zip.sha256 b/velocidrone-1.11.0.299.zip.sha256
new file mode 100644
index 000000000000..4ff56af6a429
--- /dev/null
+++ b/velocidrone-1.11.0.299.zip.sha256
@@ -0,0 +1 @@
+ce7ed4266599bdd0cef1fa8165ef75eebdba8e1a78214db489caf352a5dee140 velocidrone-1.11.0.299.zip
diff --git a/velocidrone.desktop b/velocidrone.desktop
new file mode 100644
index 000000000000..e194e9622c56
--- /dev/null
+++ b/velocidrone.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.11.0.299
+Name=Velocidrone
+Exec=/opt/velocidrone/velocidrone.x86_64
+Icon=/opt/velocidrone/icon.png
+Terminal=false
+Type=Application
+Categories=Game;
+Comment=Fast paced FPV drone racing action with multiplayer and offline modes!
+Keyword=Simulator;RC;Quadcopter;Multicopter;
+