summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBakasura2021-10-22 21:37:51 -0500
committerBakasura2021-10-22 21:37:51 -0500
commit6c766d4c2c368c66f1615e8e645bc291aa5f5f5b (patch)
tree948b048ed7eb19e0d2eced4464d71d7ea1175e65
parentba2617635064ca6e8167c53b7b30828513aae7fc (diff)
downloadaur-6c766d4c2c368c66f1615e8e645bc291aa5f5f5b.tar.gz
Use C++11 to complie again
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--Velocity.patch12
-rw-r--r--XboxInternals.patch12
4 files changed, 39 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bf18ff6924b..00f3688e51cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = velocity-xbox360-git
pkgdesc = A cross-platform application built using the Qt framework which allows you to browse and edit Xbox 360 files.
pkgver = 0.1.0.0.r1256.2c15bb6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hetelek/Velocity.git
arch = i686
arch = x86_64
@@ -13,9 +13,12 @@ pkgbase = velocity-xbox360-git
source = velocity-xbox360-git::git://github.com/hetelek/Velocity.git
source = velocity.desktop
source = libbotan-version.patch
+ source = Velocity.patch
+ source = XboxInternals.patch
sha512sums = SKIP
sha512sums = 1855384f6dd07a86f97da17a538771c51959a800b5951f86dbbdccb7002dd48e611b3bf1f0c5f889f318a48d4c7b4d99e568064bffcebffc6c08aff915bb03ae
sha512sums = b1dd7053f8bca090ac47b47ec04914a960d3282ddcd742872b33ca98b647644ee4812db0a759d6706b521e9dd356ca2483da4eb98c453640b686955787df55f2
+ sha512sums = e3c649bf046ed11428a5da4b3d7bcf8f077b0e59a2efc28a4cf93eee67fe998f047d4ecb8af823d0655db6d63185e1d849bdb20837d310493896cfcf8ed3b893
+ sha512sums = 2d08089d08cc00d07a7966b28cd84fdc483f79a982fed489ab5e3352c2cec149a069b8a3eb077c9179fa74b254190ee4619068356d4782f1f85ca6aa330a7798
pkgname = velocity-xbox360-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2a6fa7e618ba..6357c6c282fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Lubomir 'Kuci' Kucera <kuci24-at-gmail-dot-com>
+# Maintainer: Bakasura <bakasura-at-protonmail-dot-ch>
pkgname=velocity-xbox360-git
pkgver=0.1.0.0.r1256.2c15bb6
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application built using the Qt framework which allows you to browse and edit Xbox 360 files."
arch=('i686' 'x86_64')
url="https://github.com/hetelek/Velocity.git"
@@ -12,14 +13,20 @@ makedepends=('git')
options=('!makeflags')
source=("$pkgname"::'git://github.com/hetelek/Velocity.git'
'velocity.desktop'
- 'libbotan-version.patch')
+ 'libbotan-version.patch'
+ 'Velocity.patch'
+ 'XboxInternals.patch')
sha512sums=('SKIP'
'1855384f6dd07a86f97da17a538771c51959a800b5951f86dbbdccb7002dd48e611b3bf1f0c5f889f318a48d4c7b4d99e568064bffcebffc6c08aff915bb03ae'
- 'b1dd7053f8bca090ac47b47ec04914a960d3282ddcd742872b33ca98b647644ee4812db0a759d6706b521e9dd356ca2483da4eb98c453640b686955787df55f2')
+ 'b1dd7053f8bca090ac47b47ec04914a960d3282ddcd742872b33ca98b647644ee4812db0a759d6706b521e9dd356ca2483da4eb98c453640b686955787df55f2'
+ 'e3c649bf046ed11428a5da4b3d7bcf8f077b0e59a2efc28a4cf93eee67fe998f047d4ecb8af823d0655db6d63185e1d849bdb20837d310493896cfcf8ed3b893'
+ '2d08089d08cc00d07a7966b28cd84fdc483f79a982fed489ab5e3352c2cec149a069b8a3eb077c9179fa74b254190ee4619068356d4782f1f85ca6aa330a7798')
prepare() {
cd "$srcdir/$pkgname"
patch -Np1 -i "${srcdir}/libbotan-version.patch"
+ patch -Np0 -i "${srcdir}/Velocity.patch"
+ patch -Np0 -i "${srcdir}/XboxInternals.patch"
}
pkgver() {
diff --git a/Velocity.patch b/Velocity.patch
new file mode 100644
index 000000000000..2cfc39594d30
--- /dev/null
+++ b/Velocity.patch
@@ -0,0 +1,12 @@
+--- Velocity/Velocity.pro 2021-10-22 21:02:51.526429000 -0500
++++ Velocity/Velocity.pro 2021-10-22 21:03:28.195891997 -0500
+@@ -16,6 +16,9 @@
+ VERSION = 0.1.0.0
+ DEFINES += VERSION=\\\"$$VERSION\\\"
+
++QMAKE_CXXFLAGS += -std=c++0x
++QMAKE_CLFLAGS += -std=c++0x
++
+ # linking against botan (and adding to include path)
+ win32 {
+ LIBS += -LC:/botan/ -lbotan-1.10
diff --git a/XboxInternals.patch b/XboxInternals.patch
new file mode 100644
index 000000000000..334257bdccd9
--- /dev/null
+++ b/XboxInternals.patch
@@ -0,0 +1,12 @@
+--- XboxInternals/XboxInternals.pro 2021-10-22 21:02:53.429735000 -0500
++++ XboxInternals/XboxInternals.pro 2021-10-22 21:03:29.022546431 -0500
+@@ -15,6 +15,9 @@
+ # flags (lets step it up a notch)
+ QMAKE_CXXFLAGS = -O3
+
++QMAKE_CXXFLAGS += -std=c++0x
++QMAKE_CLFLAGS += -std=c++0x
++
+ # linking against botan (and adding to include path)
+ win32 {
+ include(Stfs/Botan.pri)