summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Zankich2020-05-12 23:23:24 +0000
committerAdrian Zankich2020-05-12 23:23:24 +0000
commit97e2cfd71f601b298c96cb213e51fe69b94a51cc (patch)
treef0bc16bb4a8d783a0a9f3440c4d7baf44625ab97
downloadaur-97e2cfd71f601b298c96cb213e51fe69b94a51cc.tar.gz
Initial upload: kapp-bin 0.26.0-1
Initial upload: kbld-bin 0.21.0-1 Initial upload: vendir-bin 0.8.0-1 Initial upload: ytt-bin 0.27.1-1 Squash history to include SRCINFO files
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2369688cc73b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vendir-bin
+ pkgdesc = Easy way to vendor portions of git repos, github releases, etc. declaratively
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/k14s/vendir
+ arch = x86_64
+ groups = k14s-bin
+ license = apache
+ source = vendir-linux-amd64-v0.8.0::https://github.com/k14s/vendir/releases/download/v0.8.0/vendir-linux-amd64
+ sha256sums = 6a9afd04835020b0901c19991f138e293be99d755a5db15bed8b4dfe34920c17
+
+pkgname = vendir-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7aa3978217fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Adrian Zankich <azankich@pivotal.io>
+pkgname=vendir-bin
+pkgdesc="Easy way to vendor portions of git repos, github releases, etc. declaratively "
+pkgver=0.8.0
+pkgrel=1
+url="https://github.com/k14s/vendir"
+arch=('x86_64')
+license=('apache')
+groups=('k14s-bin')
+_binary=vendir-linux-amd64
+source=("${_binary}-v${pkgver}::https://github.com/k14s/vendir/releases/download/v${pkgver}/${_binary}")
+sha256sums=("6a9afd04835020b0901c19991f138e293be99d755a5db15bed8b4dfe34920c17")
+
+package() {
+ install -Dm 755 "${srcdir}/${_binary}-v${pkgver}" "${pkgdir}/usr/bin/vendir"
+}