summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgithub-actions[bot]2023-11-14 00:01:39 +0000
committergithub-actions[bot]2023-11-14 00:01:39 +0000
commitbf7da85a3ab7b2b38d9048894ff16062266df603 (patch)
tree7bc1ed6d558ef69a72ce61b0f0166f734e2c85b5
parent20adaea418df9f0b559f426957acaa3e2c6285e2 (diff)
downloadaur-bf7da85a3ab7b2b38d9048894ff16062266df603.tar.gz
Automatic update
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
2 files changed, 40 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6242f5ff79f8..06af89e01fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = vendir-bin
- pkgdesc = Easy way to vendor portions of git repos, github releases, etc. declaratively
- pkgver = 0.8.0
- pkgrel = 2
- url = https://github.com/k14s/vendir
+ pkgdesc = Easy way to vendor portions of git repos, github releases, helm charts, docker image contents, etc. declaratively
+ pkgver = 0.37.0
+ pkgrel = 1
+ url = https://carvel.dev/vendir
arch = x86_64
- groups = k14s-bin
- license = apache
+ arch = aarch64
+ license = apache-2.0
provides = vendir
- conflicts = vendir
- source = vendir-linux-amd64-v0.8.0::https://github.com/k14s/vendir/releases/download/v0.8.0/vendir-linux-amd64
- sha256sums = 6a9afd04835020b0901c19991f138e293be99d755a5db15bed8b4dfe34920c17
+ source_x86_64 = vendir-v0.37.0::https://github.com/carvel-dev/vendir/releases/download/v0.37.0/vendir-linux-amd64
+ sha256sums_x86_64 = f1472bf7995506830fa79473f0ae406ea3885e0881fbbb096240efb1b053dd15
+ source_aarch64 = vendir-v0.37.0::https://github.com/carvel-dev/vendir/releases/download/v0.37.0/vendir-linux-arm64
+ sha256sums_aarch64 = 7dde14730aa5a58511fc5b95f61162892ec97f87c9a57c01ab91d1f9f3d7aa74
pkgname = vendir-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 0caa3d23ba59..d629d63711df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,32 @@
-# Maintainer: Adrian Zankich <azankich@pivotal.io>
+# Maintainer: German Lashevich <german.lashevich@gmail.com>
+#
+# Source: https://github.com/zebradil/aur
+#
+# shellcheck disable=SC2034,SC2154
pkgname=vendir-bin
-pkgdesc="Easy way to vendor portions of git repos, github releases, etc. declaratively "
-pkgver=0.8.0
-pkgrel=2
-url="https://github.com/k14s/vendir"
-arch=('x86_64')
-license=('apache')
-groups=('k14s-bin')
-provides=('vendir')
-conflicts=('vendir')
-_binary=vendir-linux-amd64
-source=("${_binary}-v${pkgver}::https://github.com/k14s/vendir/releases/download/v${pkgver}/${_binary}")
-sha256sums=("6a9afd04835020b0901c19991f138e293be99d755a5db15bed8b4dfe34920c17")
-
-package() {
- install -Dm 755 "${srcdir}/${_binary}-v${pkgver}" "${pkgdir}/usr/bin/vendir"
+pkgver=0.37.0
+pkgrel=1
+pkgdesc="Easy way to vendor portions of git repos, github releases, helm charts, docker image contents, etc. declaratively"
+url="https://carvel.dev/vendir"
+arch=(x86_64 aarch64)
+license=(apache-2.0)
+provides=(vendir)
+source_x86_64=(vendir-v0.37.0::https://github.com/carvel-dev/vendir/releases/download/v0.37.0/vendir-linux-amd64)
+source_aarch64=(vendir-v0.37.0::https://github.com/carvel-dev/vendir/releases/download/v0.37.0/vendir-linux-arm64)
+sha256sums_x86_64=(f1472bf7995506830fa79473f0ae406ea3885e0881fbbb096240efb1b053dd15)
+sha256sums_aarch64=(7dde14730aa5a58511fc5b95f61162892ec97f87c9a57c01ab91d1f9f3d7aa74)
+package ()
+{
+ install -Dm 755 "${srcdir}/${_z_binname}-v${pkgver}" "${pkgdir}/usr/bin/${_z_binname}";
+ mkdir -p "$pkgdir/usr/share/bash-completion/completions/";
+ mkdir -p "$pkgdir/usr/share/zsh/site-functions/";
+ mkdir -p "$pkgdir/usr/share/fish/vendor_completions.d/";
+ ./$_z_binname completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/$_z_binname";
+ ./$_z_binname completion fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/$_z_binname.fish";
+ ./$_z_binname completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_$_z_binname"
}
+
+
+# Custom variables
+
+_z_binname="vendir"