summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-03-06 19:28:41 -0500
committerTony Lambiris2018-03-06 19:28:41 -0500
commit6639835ba2c968e0094362a74675b9eebe0ffabe (patch)
tree829769becff3b24c567b23da6e4e2380a7db23fb
parent63bc284c57fbe1e437dfb60082014da9a8cbdee1 (diff)
downloadaur-6639835ba2c968e0094362a74675b9eebe0ffabe.tar.gz
Update build
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
3 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97d051deca0f..0287ebca11a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = vendorlint-git
license = Apache
makedepends = go
makedepends = go-bindata
- source = vendorlint::git+https://github.com/mephux/vendorlint.git
+ source = vendorlint-git::git+https://github.com/mephux/vendorlint.git
md5sums = SKIP
pkgname = vendorlint-git
diff --git a/.gitignore b/.gitignore
index e91b42ce2d73..e63395e8066b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
src
pkg
-vendorlint
+vendorlint-git
*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index a5f363a0b96d..fd2cfd7f3a4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
pkgname=vendorlint-git
pkgver=r13.08816a4
-_pkgname=vendorlint
pkgrel=1
pkgdesc="Tool to ensure all dependents are properly vendored"
url="https://github.com/mephux/vendorlint"
arch=('x86_64' 'i686')
license=('Apache')
makedepends=('go' 'go-bindata')
-source=("${_pkgname}::git+https://github.com/mephux/vendorlint.git")
+source=("${pkgname}::git+https://github.com/mephux/vendorlint.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -22,7 +21,7 @@ prepare() {
cd "${srcdir}"
mkdir -p "go/src/github.com/mephux"
- ln -sf "${srcdir}/${_pkgname}" "go/src/github.com/mephux/vendorlint"
+ ln -sf "${srcdir}/${pkgname}" "go/src/github.com/mephux/vendorlint"
}
build() {
@@ -30,7 +29,7 @@ build() {
mkdir bin
GOROOT="/usr/lib/go" GOPATH="${srcdir}/go" PATH="$PATH:$GOPATH/bin" \
- go get -v github.com/mephux/vendorlint
+ go get -v -d ./...
GOROOT="/usr/lib/go" GOPATH="${srcdir}/go" PATH="$PATH:$GOPATH/bin" \
go build -o bin/vendorlint github.com/mephux/vendorlint
}