summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaxuroqa2018-06-12 09:17:09 +0200
committernaxuroqa2018-06-12 09:17:09 +0200
commit296365329d446c9724675d0cabc62df8bcd2f1a9 (patch)
treedf6120d89eb71f90c448e444db66b59d4a26d3ef
downloadaur-296365329d446c9724675d0cabc62df8bcd2f1a9.tar.gz
Venom-0.3.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e379af9e0a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = venom
+ pkgdesc = a modern Tox client for the Linux desktop
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/naxuroqa/venom
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = meson
+ depends = gtk3
+ depends = libgee
+ depends = toxcore
+ source = https://github.com/naxuroqa/Venom/archive/0.3.0.tar.gz
+ sha512sums = 8c87db50bc392d571303d69ca3f655c813f27e89dd6ce0d542f8d72277c2fece4d72fece0c22a448a36c52983400d8aaf34da33745cddcd8cbfebd8526879bdc
+
+pkgname = venom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0790f0790a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: naxuroqa <naxuroqa@gmail.com>
+
+pkgname=venom
+_pkgname=Venom
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='a modern Tox client for the Linux desktop'
+url='https://github.com/naxuroqa/venom'
+arch=(x86_64)
+license=('GPL3')
+depends=('gtk3' 'libgee' 'toxcore')
+makedepends=('vala' 'meson')
+
+source=("https://github.com/naxuroqa/$_pkgname/archive/$pkgver.tar.gz")
+sha512sums=('8c87db50bc392d571303d69ca3f655c813f27e89dd6ce0d542f8d72277c2fece4d72fece0c22a448a36c52983400d8aaf34da33745cddcd8cbfebd8526879bdc')
+
+check() {
+ ninja -C build test
+}
+
+build() {
+ arch-meson $_pkgname-$pkgver build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}