summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgS6442015-12-09 23:03:08 +0100
committergS6442015-12-09 23:03:08 +0100
commitbff8f9376de0599847aae5be20f7c3e150c8c5b7 (patch)
tree83ce53bfd84914b0642f5cf1d1be7565c772bf8e
parent533b67f493ac20a6ff38b1710613583361304414 (diff)
downloadaur-bff8f9376de0599847aae5be20f7c3e150c8c5b7.tar.gz
Enable static wxWidgets since new C++11 ABI breaks them (https://veracrypt.codeplex.com/workitem/173)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
-rw-r--r--no_glibcxx_use_cxx11_abi.patch11
3 files changed, 44 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9acb658038c..be53b081e635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Dec 9 22:02:09 UTC 2015
pkgbase = veracrypt
pkgdesc = Disk encryption with strong security based on TrueCrypt
pkgver = 1.16
- pkgrel = 3
+ pkgrel = 4
url = http://veracrypt.codeplex.com/
install = veracrypt.install
arch = i686
@@ -9,18 +11,24 @@ pkgbase = veracrypt
arch = armv6h
license = custom
makedepends = nasm
+ makedepends = webkitgtk2
+ makedepends = glu
+ makedepends = gstreamer0.10-base-plugins
depends = fuse
- depends = wxgtk>=3.0.0
depends = libsm
depends = device-mapper
source = veracrypt_1.16_Source.tar.bz2::http://sourceforge.net/projects/veracrypt/files/VeraCrypt 1.16/veracrypt_1.16_Source.tar.bz2/download
source = veracrypt_1.16_Source.tar.bz2.sig::http://sourceforge.net/projects/veracrypt/files/VeraCrypt 1.16/veracrypt_1.16_Source.tar.bz2.sig/download
+ source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.0.2/wxWidgets-3.0.2.tar.bz2
source = no_makeself.patch
+ source = no_glibcxx_use_cxx11_abi.patch
source = veracrypt.desktop
source = veracrypt.install
sha1sums = 54467b063609d854dd8f1b780201378e706f452f
sha1sums = 23db8fd6bfea26986a1034d51aa0a6826440b0ba
+ sha1sums = 6461eab4428c0a8b9e41781b8787510484dea800
sha1sums = 0cbe9f7875ab52be125cc575533f76fab60314a5
+ sha1sums = 435d3e7bb306886ba570e6249f81d7131f10510a
sha1sums = ebdd450e719fe3cff5e459f027856cbaf03db13a
sha1sums = 14dceabf658a7e3505c855c2862aa86e343fcda5
diff --git a/PKGBUILD b/PKGBUILD
index 4b18c7cc0bc0..3e869abe662f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,34 +5,49 @@ pkgname=veracrypt
_pkgname=VeraCrypt
pkgver=1.16
_pkgver=${pkgver//_/-}
-pkgrel=3
+_wxver=3.0.2
+pkgrel=4
pkgdesc="Disk encryption with strong security based on TrueCrypt"
arch=('i686' 'x86_64' 'armv6h')
url="http://veracrypt.codeplex.com/"
license=('custom')
-depends=('fuse' 'wxgtk>=3.0.0' 'libsm' 'device-mapper')
-makedepends=('nasm')
+depends=('fuse' 'libsm' 'device-mapper')
+makedepends=('nasm' 'webkitgtk2' 'glu' 'gstreamer0.10-base-plugins')
install='veracrypt.install'
source=("${pkgname}_${pkgver}_Source.tar.bz2::http://sourceforge.net/projects/${pkgname}/files/${_pkgname} ${pkgver}/${pkgname}_${pkgver}_Source.tar.bz2/download"
"${pkgname}_${pkgver}_Source.tar.bz2.sig::http://sourceforge.net/projects/${pkgname}/files/${_pkgname} ${pkgver}/${pkgname}_${pkgver}_Source.tar.bz2.sig/download"
+ "https://github.com/wxWidgets/wxWidgets/releases/download/v${_wxver}/wxWidgets-${_wxver}.tar.bz2"
"no_makeself.patch"
+ "no_glibcxx_use_cxx11_abi.patch"
"veracrypt.desktop"
"veracrypt.install")
sha1sums=('54467b063609d854dd8f1b780201378e706f452f'
'23db8fd6bfea26986a1034d51aa0a6826440b0ba'
+ '6461eab4428c0a8b9e41781b8787510484dea800'
'0cbe9f7875ab52be125cc575533f76fab60314a5'
+ '435d3e7bb306886ba570e6249f81d7131f10510a'
'ebdd450e719fe3cff5e459f027856cbaf03db13a'
'14dceabf658a7e3505c855c2862aa86e343fcda5')
-#validpgpkeys=('0x54DDD393')
validpgpkeys=('993B7D7E8E413809828F0F29EB559C7C54DDD393')
-build() {
+prepare() {
cd ${srcdir}/src
- msg2 "Applying patch..."
+ msg2 "Applying patches..."
patch -Np1 -i ../no_makeself.patch # disable sfx archive
- # build
- export WX_CONFIG=/usr/bin/wx-config
+ patch -Np1 -i ../no_glibcxx_use_cxx11_abi.patch
+}
+
+build() {
+ cd ${srcdir}/src
+
+ msg2 "Building static wxWidgets..."
+ export WX_ROOT="${srcdir}/wxWidgets-${_wxver}"
+ export WXSTATIC=1
+ make wxbuild
+
+ msg2 "Building veracrypt..."
+# export WX_CONFIG=/usr/bin/wx-config
make LFLAGS+="-ldl"
}
diff --git a/no_glibcxx_use_cxx11_abi.patch b/no_glibcxx_use_cxx11_abi.patch
new file mode 100644
index 000000000000..ee92bc02790b
--- /dev/null
+++ b/no_glibcxx_use_cxx11_abi.patch
@@ -0,0 +1,11 @@
+--- old/Makefile 2015-12-09 22:38:14.011044205 +0100
++++ src/Makefile 2015-12-09 22:38:48.384227463 +0100
+@@ -41,7 +41,7 @@
+
+ export CFLAGS := -Wall
+ export CXXFLAGS := -Wall -Wno-unused-parameter
+-C_CXX_FLAGS := -MMD -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
++C_CXX_FLAGS := -MMD -D_GLIBCXX_USE_CXX11_ABI=0 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
+ export ASFLAGS := -Ox -D __GNUC__
+ export LFLAGS :=
+