summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-07-21 00:38:55 +0200
committerAlphaJack2021-07-21 00:53:18 +0200
commit625616b540a797bb125efea8e30bad76a97c69d6 (patch)
tree7b4fb51e2f07f9b66a753ab82810dd12a89e8a17
downloadaur-625616b540a797bb125efea8e30bad76a97c69d6.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
-rw-r--r--veracrypt.install6
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c189ef61eba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = veracrypt-console-bin
+ pkgdesc = Disk encryption with strong security based on TrueCrypt. amd64 and armv7h headless versions only
+ pkgver = 1.24.update7
+ pkgrel = 1
+ url = https://www.veracrypt.fr/
+ install = veracrypt.install
+ arch = x86_64
+ arch = armv7h
+ license = custom:TrueCrypt
+ depends = fuse2>=2.8.0
+ depends = libsm
+ depends = device-mapper
+ optdepends = sudo: mounting encrypted volumes as nonroot users
+ provides = veracrypt
+ conflicts = veracrypt
+ conflicts = veracrypt-git
+ source_x86_64 = veracrypt-console-bin-1.24.update7.deb::https://launchpad.net/veracrypt/trunk/1.24-update7/+download/veracrypt-console-1.24-Update7-Debian-10-amd64.deb
+ sha256sums_x86_64 = c76e1017c8c1d1a904be10a3594c7a8144acc4391977b1dce5d4481f596112da
+ source_armv7h = veracrypt-console-bin-1.24.update7.deb::https://launchpad.net/veracrypt/trunk/1.24-update7/+download/veracrypt-console-1.24-Update7-Debian-10-armhf.deb
+ sha256sums_armv7h = 99a3b5f170804aa0f80d9c5129db80e55da94976bf8fd3af7c68c14089fbc00a
+
+pkgname = veracrypt-console-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51994ee01794
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="veracrypt-console-bin"
+_pkgver=1.24
+_updatever=7
+pkgver="${_pkgver}.update${_updatever}"
+pkgrel=1
+pkgdesc="Disk encryption with strong security based on TrueCrypt. amd64 and armv7h headless versions only"
+url="https://www.veracrypt.fr/"
+arch=("x86_64" "armv7h") # no other architectures are available from the official download page
+license=("custom:TrueCrypt")
+provides=("veracrypt")
+conflicts=("veracrypt" "veracrypt-git")
+depends=("fuse2>=2.8.0" "libsm" "device-mapper")
+optdepends=("sudo: mounting encrypted volumes as nonroot users")
+source_x86_64=("$pkgname-$pkgver.deb::https://launchpad.net/veracrypt/trunk/$_pkgver-update$_updatever/+download/${pkgname/-bin/}-$_pkgver-Update$_updatever-Debian-10-amd64.deb")
+source_armv7h=("$pkgname-$pkgver.deb::https://launchpad.net/veracrypt/trunk/$_pkgver-update$_updatever/+download/${pkgname/-bin/}-$_pkgver-Update$_updatever-Debian-10-armhf.deb")
+sha256sums_x86_64=("c76e1017c8c1d1a904be10a3594c7a8144acc4391977b1dce5d4481f596112da")
+sha256sums_armv7h=("99a3b5f170804aa0f80d9c5129db80e55da94976bf8fd3af7c68c14089fbc00a")
+install="veracrypt.install"
+
+prepare(){
+ tar -xf "data.tar.gz"
+}
+
+package(){
+ cp -r "usr" "$pkgdir"
+ rm "$pkgdir/usr/bin/veracrypt-uninstall.sh"
+ install -D -m 644 "$pkgdir/usr/share/doc/veracrypt/License.txt" -t "$pkgdir/usr/share/licenses/veracrypt/LICENSE"
+}
diff --git a/veracrypt.install b/veracrypt.install
new file mode 100644
index 000000000000..5d125fabf1b4
--- /dev/null
+++ b/veracrypt.install
@@ -0,0 +1,6 @@
+pre_remove(){
+ if [[ "$(mount)" =~ "veracrypt_aux_mnt" ]]; then
+ echo "Error: All VeraCrypt volumes must be dismounted first."
+ exit 1
+ fi
+}