summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2023-03-02 17:05:39 +0100
committerClaudia Pellegrino2023-03-02 17:06:05 +0100
commit12f4353a90ae5cfb14e01c31fdfdc2b7eb31d58b (patch)
treee3b3323cc317bcb4f25dd1d72e47c3e4ead97c7e
parentdd1b25514aea49d1dbddf1a1569146e903427d95 (diff)
downloadaur-12f4353a90ae5cfb14e01c31fdfdc2b7eb31d58b.tar.gz
Add .editorconfig, .gitattributes
-rw-r--r--.editorconfig20
-rw-r--r--.gitattributes8
2 files changed, 28 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..cf06dd3ed5ab
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[.gitattributes]
+indent_size = 16
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..7de6c048ded0
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,8 @@
+.editorconfig text eol=lf
+.gitattributes text eol=lf
+
+# LF required for interactive patching as of Git 2.17.1
+*.diff text eol=lf
+*.patch text eol=lf
+
+PKGBUILD text eol=lf