summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-18 19:19:58 -0500
committerclintval2017-12-18 19:19:58 -0500
commit52a1d912a83df636bea9506017872f7b0a428252 (patch)
tree68fdac41bc354f0e20a2fb37f88003b3bf91c9f4
downloadaur-52a1d912a83df636bea9506017872f7b0a428252.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe1d2790f2d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = verifybamid
+ pkgdesc = Bioinformatics tool that verifies if reads in a particular file match previously known genotypes for an individual (or group of individuals)
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://genome.sph.umich.edu/wiki/VerifyBamID
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc-libs
+ makedepends = zlib
+ provides = verifybamid
+ conflicts = verifybamid
+ source = https://github.com/statgen/verifyBamID/archive/v1.1.3.tar.gz
+ source = libStatGen::git+https://github.com/statgen/libStatGen.git#commit=9db9c23e176a6ce6f421a3c21ccadedca892ac0c
+ md5sums = d542ca13e68b51e976d7f139ddee8cf5
+ md5sums = SKIP
+
+pkgname = verifybamid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d8b87ecba92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=verifybamid
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="Bioinformatics tool that verifies if reads in a particular file match previously known genotypes for an individual (or group of individuals)"
+arch=('x86_64')
+url="https://genome.sph.umich.edu/wiki/VerifyBamID"
+license=('GPL3')
+depends=()
+makedepends=('gcc-libs' 'zlib')
+provides=('verifybamid')
+conflicts=('verifybamid')
+source=(
+ "https://github.com/statgen/verifyBamID/archive/v${pkgver}.tar.gz"
+ "libStatGen::git+https://github.com/statgen/libStatGen.git#commit=9db9c23e176a6ce6f421a3c21ccadedca892ac0c")
+md5sums=('d542ca13e68b51e976d7f139ddee8cf5' 'SKIP')
+
+build() {
+ cd "${srcdir}/verifyBamID-${pkgver}"
+
+ make
+}
+
+check() {
+ cd "${srcdir}/verifyBamID-${pkgver}"
+
+ make test
+}
+
+package() {
+ cd "${srcdir}/verifyBamID-${pkgver}"
+
+ install -Dm775 "bin/verifyBamID" "${pkgdir}/usr/bin/verifyBamID"
+ install -Dm644 "copyrights/LICENSE.txt" "${pkgdir}/usr/share/licenses/verifyBamID-${pkgver}/LICENSE.txt"
+ install -Dm644 "copyrights/COPYING" "${pkgdir}/usr/share/licenses/verifyBamID-${pkgver}/COPYING"
+ install -Dm644 "src/base/LICENSE" "${pkgdir}/usr/share/licenses/verifyBamID-${pkgver}/LICENSE_Chromium"
+}
+