summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvertiond2022-04-18 20:07:04 -0500
committervertiond2022-04-18 20:50:51 -0500
commit486dfa8a89ac707e7ede59097e81718a43261e92 (patch)
treea934683bb99019f4886bf475032041a598217112
downloadaur-486dfa8a89ac707e7ede59097e81718a43261e92.tar.gz
Add Vertcoin pkgbase
-rw-r--r--.SRCINFO68
-rw-r--r--Changelog1
-rw-r--r--PKGBUILD112
-rw-r--r--vertcoin-qt.appdata.xml24
-rw-r--r--vertcoin-qt.desktop13
-rw-r--r--vertcoin.sysusers1
-rw-r--r--vertcoin.tmpfiles2
7 files changed, 221 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a63d727d902b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,68 @@
+pkgbase = vertcoin
+ pkgver = 0.18.0
+ pkgrel = 1
+ url = https://www.vertcoin.org/
+ changelog = Changelog
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = libevent
+ makedepends = qt5-base
+ makedepends = qt5-tools
+ makedepends = qrencode
+ makedepends = miniupnpc
+ makedepends = protobuf
+ makedepends = zeromq
+ makedepends = gmp
+ source = vertcoin-daemon-0.18.0.tar.gz::https://github.com/vertcoin-project/vertcoin-core/archive/refs/tags/0.18.0.tar.gz
+ source = vertcoin.sysusers
+ source = vertcoin.tmpfiles
+ source = vertcoin-qt.desktop
+ source = vertcoin-qt.appdata.xml
+ validpgpkeys = 28E72909F1717FE9607754F8A7BEB2621678D37D
+ sha256sums = c49c477b214fe4b47ba17861a9305aca15074554170599811332372a334a60b5
+ sha256sums = 3cd12f27d9af2957cdb163518869de5d162da1247f7677f185c9d70d38882ace
+ sha256sums = a86e6169531e7cc1dbec67d448c48d586ca97616078d0ce1d0e72ee5c38f2997
+ sha256sums = b303f138e0d86d9819432a3559bb5397e41ca79a08fa5677a09cfbb15cb85165
+ sha256sums = e6894e103f6f438070723a592cd7a905ec304aaa3592fe2aad72e9eb6cd618d5
+ b2sums = 762ad7095c8a297a6becfa834f89de8ea2ab52701c4b3d941335234465b737cab69420ff7c2e0326432d7056983fb84873be9a59de698c3f8c9231390c8c7f78
+ b2sums = 257f2d33148559afd622e597b1398c94447f432527bb79776e716944fd2de21f8909d421ddca25f9ae758ccb759d60db91186215f852ac8fc660d49edf2a5d77
+ b2sums = 38b97d6e7f064af6ad2bef56b87f7067805db921d5a651f04cae255778eecfbf96cf9f439318be10853666e609ff49dc7004be90bc6a774dad36351e75c96971
+ b2sums = 98feb764243fd3fd6d899dd7d9429996cb3c346cff9f4dcbafd609e68714973a4e78ab3dd1e7e66b81ab73c1a35277fcf1ae6b5cbea5288480b48438c47646fc
+ b2sums = 8671f280b84b092c9c5d2011fdad646130c4c03cf3c67da5a70025e8646ce5f268884307f1b9d4a4652227a448ee50c59757391d81be698f8912e1a45350c285
+
+pkgname = vertcoin-daemon
+ pkgdesc = Vertcoin is a peer-to-peer network based digital currency - daemon
+ depends = boost-libs
+ depends = db
+ depends = libevent
+ depends = miniupnpc
+ depends = libminiupnpc.so
+ depends = sqlite
+ depends = zeromq
+ depends = gmp
+ backup = etc/vertcoin/vertcoin.conf
+
+pkgname = vertcoin-cli
+ pkgdesc = Vertcoin is a peer-to-peer network based digital currency - RPC client
+ depends = boost-libs
+ depends = libevent
+
+pkgname = vertcoin-qt
+ pkgdesc = Vertcoin is a peer-to-peer network based digital currency - Qt
+ depends = boost-libs
+ depends = libevent
+ depends = qt5-base
+ depends = miniupnpc
+ depends = libminiupnpc.so
+ depends = qrencode
+ depends = protobuf
+ depends = zeromq
+ depends = hicolor-icon-theme
+ depends = db
+ depends = gmp
+
+pkgname = vertcoin-tx
+ pkgdesc = Vertcoin is a peer-to-peer network based digital currency - Transaction tool
+ depends = boost-libs
+ depends = openssl \ No newline at end of file
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..ecdbcbb4e3b6
--- /dev/null
+++ b/Changelog
@@ -0,0 +1 @@
+https://github.com/vertcoin-project/vertcoin-core/blob/master/doc/release-notes.md \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6bcd6dd7a84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,112 @@
+# Maintainer: vertion <vertion@protonmail.com>
+
+pkgbase=vertcoin
+pkgname=('vertcoin-daemon' 'vertcoin-cli' 'vertcoin-qt' 'vertcoin-tx')
+pkgver=0.18.0
+pkgrel=1
+arch=('x86_64')
+url="https://www.vertcoin.org/"
+makedepends=('boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq' 'gmp')
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vertcoin-project/vertcoin-core/archive/refs/tags/$pkgver.tar.gz"
+
+ "vertcoin.sysusers"
+ "vertcoin.tmpfiles"
+ "vertcoin-qt.desktop"
+ "vertcoin-qt.appdata.xml")
+sha256sums=('c49c477b214fe4b47ba17861a9305aca15074554170599811332372a334a60b5'
+ '3cd12f27d9af2957cdb163518869de5d162da1247f7677f185c9d70d38882ace'
+ 'a86e6169531e7cc1dbec67d448c48d586ca97616078d0ce1d0e72ee5c38f2997'
+ 'b303f138e0d86d9819432a3559bb5397e41ca79a08fa5677a09cfbb15cb85165'
+ 'e6894e103f6f438070723a592cd7a905ec304aaa3592fe2aad72e9eb6cd618d5')
+b2sums=('762ad7095c8a297a6becfa834f89de8ea2ab52701c4b3d941335234465b737cab69420ff7c2e0326432d7056983fb84873be9a59de698c3f8c9231390c8c7f78'
+ '257f2d33148559afd622e597b1398c94447f432527bb79776e716944fd2de21f8909d421ddca25f9ae758ccb759d60db91186215f852ac8fc660d49edf2a5d77'
+ '38b97d6e7f064af6ad2bef56b87f7067805db921d5a651f04cae255778eecfbf96cf9f439318be10853666e609ff49dc7004be90bc6a774dad36351e75c96971'
+ '98feb764243fd3fd6d899dd7d9429996cb3c346cff9f4dcbafd609e68714973a4e78ab3dd1e7e66b81ab73c1a35277fcf1ae6b5cbea5288480b48438c47646fc'
+ '8671f280b84b092c9c5d2011fdad646130c4c03cf3c67da5a70025e8646ce5f268884307f1b9d4a4652227a448ee50c59757391d81be698f8912e1a45350c285')
+validpgpkeys=(28E72909F1717FE9607754F8A7BEB2621678D37D)
+changelog=Changelog
+
+prepare() {
+ cd "$pkgbase-core-$pkgver"
+ autoreconf -fi
+}
+
+build() {
+ cd $pkgbase-core-$pkgver
+ ./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb --disable-tests --disable-bench --disable-dependency-tracking
+ make
+}
+
+package_vertcoin-qt() {
+ pkgdesc="Vertcoin is a peer-to-peer network based digital currency - Qt"
+ depends=(boost-libs libevent qt5-base miniupnpc libminiupnpc.so qrencode protobuf zeromq hicolor-icon-theme db gmp)
+
+ cd $pkgbase-core-$pkgver
+ install -Dm755 src/qt/vertcoin-qt "$pkgdir"/usr/bin/vertcoin-qt
+ install -Dm644 doc/man/vertcoin-qt.1 \
+ "$pkgdir"/usr/share/man/man1/vertcoin-qt.1
+ install -Dm644 ../vertcoin-qt.desktop \
+ "$pkgdir"/usr/share/applications/vertcoin-qt.desktop
+ install -Dm644 ../vertcoin-qt.appdata.xml \
+ "$pkgdir"/usr/share/metainfo/vertcoin-qt.appdata.xml
+ install -Dm644 share/pixmaps/vertcoin256.png \
+ "$pkgdir"/usr/share/icons/hicolor/256x256/apps/vertcoin-qt.png
+
+ for i in 16 32 64 128 256; do
+ install -Dm644 share/pixmaps/vertcoin${i}.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/vertcoin-qt.png
+ done
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+package_vertcoin-daemon() {
+ pkgdesc="Vertcoin is a peer-to-peer network based digital currency - daemon"
+ depends=(boost-libs db libevent miniupnpc libminiupnpc.so sqlite zeromq gmp)
+ backup=('etc/vertcoin/vertcoin.conf')
+
+ cd $pkgbase-core-$pkgver
+ install -Dm755 src/vertcoind "$pkgdir"/usr/bin/vertcoind
+ install -Dm644 contrib/bitcoind.bash-completion \
+ "$pkgdir"/usr/share/bash-completion/completions/vertcoind
+ install -Dm644 doc/man/vertcoind.1 \
+ "$pkgdir"/usr/share/man/man1/vertcoind.1
+ install -Dm644 "$srcdir/vertcoin.sysusers" \
+ "$pkgdir/usr/lib/sysusers.d/vertcoin.conf"
+ install -Dm644 "$srcdir/vertcoin.tmpfiles" \
+ "$pkgdir/usr/lib/tmpfiles.d/vertcoin.conf"
+ mv share/examples/bitcoin.conf share/examples/vertcoin.conf
+ install -Dm644 share/examples/vertcoin.conf \
+ "$pkgdir/etc/vertcoin/vertcoin.conf"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+package_vertcoin-cli() {
+ pkgdesc="Vertcoin is a peer-to-peer network based digital currency - RPC client"
+ depends=(boost-libs libevent)
+
+ cd $pkgbase-core-$pkgver
+ install -Dm755 src/vertcoin-cli "$pkgdir"/usr/bin/vertcoin-cli
+ install -Dm644 contrib/bitcoin-cli.bash-completion \
+ "$pkgdir"/usr/share/bash-completion/completions/vertcoin-cli
+ install -Dm644 doc/man/vertcoin-cli.1 \
+ "$pkgdir"/usr/share/man/man1/vertcoin-cli.1
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+package_vertcoin-tx() {
+ pkgdesc="Vertcoin is a peer-to-peer network based digital currency - Transaction tool"
+ depends=(boost-libs openssl)
+
+ cd $pkgbase-core-$pkgver
+ install -Dm755 src/vertcoin-tx "$pkgdir"/usr/bin/vertcoin-tx
+ install -Dm644 contrib/bitcoin-tx.bash-completion \
+ "$pkgdir"/usr/share/bash-completion/completions/vertcoin-tx
+ install -Dm644 doc/man/vertcoin-tx.1 \
+ "$pkgdir"/usr/share/man/man1/vertcoin-tx.1
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/vertcoin-qt.appdata.xml b/vertcoin-qt.appdata.xml
new file mode 100644
index 000000000000..2836e9c7c7cf
--- /dev/null
+++ b/vertcoin-qt.appdata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop-application">
+ <id>org.vertcoin.vertcoin-qt</id>
+ <name>Vertcoin Core</name>
+ <project_license>MIT</project_license>
+ <metadata_license>CC0-1.0</metadata_license>
+ <summary>Connect to the Vertcoin P2P network</summary>
+ <url type="homepage">https://vertcoin.org/</url>
+ <url type="bugtracker">https://github.com/vertcoin-project/vertcoin-core/issues</url>
+ <launchable type="desktop-id">vertcoin-qt.desktop</launchable>
+ <description>
+ <p>Vertcoin is an experimental digital currency that enables instant
+ payments to anyone, anywhere in the world. Vertcoin uses
+ peer-to-peer technology to operate with no central authority:
+ managing transactions and issuing money are carried out
+ collectively by the network. Vertcoin Core is the name of open
+ source software which enables the use of this currency.</p>
+ </description>
+ <screenshots>
+ <screenshot>
+ <image type="source">https://user-images.githubusercontent.com/35286924/163062174-4ba93f68-acca-4de3-b8a4-668182b2a7c6.png</image>
+ </screenshot>
+ </screenshots>
+</component>
diff --git a/vertcoin-qt.desktop b/vertcoin-qt.desktop
new file mode 100644
index 000000000000..810a83676870
--- /dev/null
+++ b/vertcoin-qt.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Vertcoin Core
+Comment=Connect to the Vertcoin P2P Network
+Comment[de]=Verbinde mit dem Vertcoin peer-to-peer Netzwerk
+Comment[fr]=Vertcoin, monnaie virtuelle cryptographique pair à pair
+Comment[tr]=Vertcoin, eşten eşe kriptografik sanal para birimi
+Exec=vertcoin-qt %u
+Terminal=false
+Type=Application
+Icon=vertcoin-qt
+MimeType=x-scheme-handler/vertcoin;
+Categories=Office;Finance;P2P;Network;Qt;
+StartupWMClass=Vertcoin-qt
diff --git a/vertcoin.sysusers b/vertcoin.sysusers
new file mode 100644
index 000000000000..2e5cdcb2145a
--- /dev/null
+++ b/vertcoin.sysusers
@@ -0,0 +1 @@
+u vertcoin - - /var/lib/vertcoind \ No newline at end of file
diff --git a/vertcoin.tmpfiles b/vertcoin.tmpfiles
new file mode 100644
index 000000000000..a75c8df00d9c
--- /dev/null
+++ b/vertcoin.tmpfiles
@@ -0,0 +1,2 @@
+d /var/lib/vertcoind 0770 vertcoin vertcoin - -
+d /etc/vertcoin 0770 vertcoin vertcoin - - \ No newline at end of file