summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-06-15 01:18:13 +0200
committerAdrian Perez de Castro2015-06-15 01:18:38 +0200
commitd2207041b2da74e5df07942f47e5aa02484f2ad0 (patch)
tree77b3eba3fd05d8ba5221ea86d0c718ff57430737
downloadaur-d2207041b2da74e5df07942f47e5aa02484f2ad0.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
-rw-r--r--vertex-icons-git.install11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44d2b2b94ec4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vertex-icons-git
+ pkgdesc = A Gnome icon theme to match the Vertex Gtk theme
+ pkgver = r16.f27e47e
+ pkgrel = 2
+ url = https://github.com/horst3180/Vertex-Icons/
+ install = vertex-icons-git.install
+ arch = any
+ license = GPL
+ depends = moka-icon-theme-git
+ depends = faba-mono-icons-git
+ source = vertex-icons-git::git://github.com/horst3180/Vertex-Icons.git
+ sha512sums = SKIP
+
+pkgname = vertex-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27cedce842b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Adrián Pérez de Castro
+pkgname='vertex-icons-git'
+pkgdesc='A Gnome icon theme to match the Vertex Gtk theme'
+pkgver=r16.f27e47e
+pkgrel=2
+url='https://github.com/horst3180/Vertex-Icons/'
+depends=('moka-icon-theme-git' 'faba-mono-icons-git')
+arch=('any')
+license='GPL'
+source=("${pkgname}::git://github.com/horst3180/Vertex-Icons.git")
+install="${pkgname}.install"
+sha512sums=('SKIP')
+
+pkgver () {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build () {
+ :
+}
+
+package () {
+ cd "${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/icons/Vertex-Icons"
+ for i in * ; do
+ if [[ -d ${i} ]] ; then
+ echo "Installing: ${i}..."
+ cp -r "${i}" "${pkgdir}/usr/share/icons/Vertex-Icons"
+ fi
+ done
+ install -Dm644 index.theme \
+ "${pkgdir}/usr/share/icons/Vertex-Icons/index.theme"
+}
diff --git a/vertex-icons-git.install b/vertex-icons-git.install
new file mode 100644
index 000000000000..73b546040844
--- /dev/null
+++ b/vertex-icons-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/Vertex-Icons
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}