summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCanalGuada2016-10-12 16:02:44 +0200
committerCanalGuada2016-10-12 16:02:44 +0200
commitb3a79547a7c022861195baa8a7205ef4aa213b2d (patch)
tree0f2d2b6307a89c4002279a617d03acfbeb9026df
parente94ca2419f70bff16c1aa1d1d932660c4e69b857 (diff)
downloadaur-b3a79547a7c022861195baa8a7205ef4aa213b2d.tar.gz
Switch to GNOME 3.22 version
No official release yet Switch to VCS source
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04c3adc76fa7..691808b50c56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = vertex-themes
- pkgdesc = Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.20 version)
- pkgver = 20160329
- pkgrel = 2
+ pkgdesc = Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.22 version)
+ pkgver = 20161009
+ pkgrel = 1
url = http://horst3180.deviantart.com/art/Vertex-Theme-470663601
arch = any
license = GPL3
+ makedepends = git
depends = gtk-engine-murrine
conflicts = vertex-themes-git
- source = vertex-themes-20160329.tar.gz::https://github.com/horst3180/Vertex-theme/archive/20160329.tar.gz
- sha256sums = c075c9fc059a5b2e30e65242a000083b5f8621a5cdfebb7ac61c31e33c6cbe85
+ source = vertex-themes::git+https://github.com/horst3180/Vertex-theme.git#commit=c861918a7fccf6d0768d45d790a19a13bb23485e
+ sha256sums = SKIP
pkgname = vertex-themes
diff --git a/PKGBUILD b/PKGBUILD
index aa8f2dc50e59..5155a932fdba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,37 @@
# Author: horst3180 @ deviantart
pkgname=vertex-themes
-pkgver=20160329
-pkgrel=2
-pkgdesc='Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.20 version)'
-_gnomever=3.20
-_releasever=20160329
+pkgver=20161009
+pkgrel=1
+pkgdesc='Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.22 version)'
+_gnomever=3.22
arch=('any')
url='http://horst3180.deviantart.com/art/Vertex-Theme-470663601'
license=('GPL3')
depends=('gtk-engine-murrine')
+makedepends=('git')
conflicts=('vertex-themes-git')
-source=("${pkgname}-${_releasever}.tar.gz::https://github.com/horst3180/Vertex-theme/archive/${_releasever}.tar.gz")
-sha256sums=('c075c9fc059a5b2e30e65242a000083b5f8621a5cdfebb7ac61c31e33c6cbe85')
+source=($pkgname::git+https://github.com/horst3180/Vertex-theme.git#commit=c861918a7fccf6d0768d45d790a19a13bb23485e)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ # get number of last git commit
+ _commitCount=$(git rev-list --count HEAD)
+ # get time of last git commit
+ _commitTime=$(git show -s --format="%ci" | grep -o "....-..-.." | sed "s/-//g")
+ # add "r*.*" from package version
+ #echo "r$_commitCount.$_commitTime"
+ echo "$_commitTime"
+}
build() {
- cd vertex-theme-${_releasever}
+ cd $pkgname
+
./autogen.sh --prefix=/usr --with-gnome=${_gnomever}
}
package() {
- cd vertex-theme-${_releasever}
+ cd $pkgname
make DESTDIR="$pkgdir" install
cd extra