summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCanalGuada2017-01-29 15:13:33 +0100
committerCanalGuada2017-01-29 15:13:33 +0100
commitc93d4651c5cacc96160d8efa80c2555e1752f383 (patch)
tree7c5f3389fd0de57fa2bee927cc70abca79b2eda3
parentb3a79547a7c022861195baa8a7205ef4aa213b2d (diff)
downloadaur-c93d4651c5cacc96160d8efa80c2555e1752f383.tar.gz
New release 20170128-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 9 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 691808b50c56..fd37e9ffbe2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = vertex-themes
pkgdesc = Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.22 version)
- pkgver = 20161009
+ pkgver = 20170128
pkgrel = 1
url = http://horst3180.deviantart.com/art/Vertex-Theme-470663601
arch = any
license = GPL3
- makedepends = git
depends = gtk-engine-murrine
conflicts = vertex-themes-git
- source = vertex-themes::git+https://github.com/horst3180/Vertex-theme.git#commit=c861918a7fccf6d0768d45d790a19a13bb23485e
- sha256sums = SKIP
+ source = vertex-themes-20170128.tar.gz::https://github.com/horst3180/Vertex-theme/archive/20170128.tar.gz
+ sha256sums = 1540657ff247bcdb9c49a740e4ddf305aecd4f3bebc93ca566fe74d319b7a620
pkgname = vertex-themes
diff --git a/PKGBUILD b/PKGBUILD
index 5155a932fdba..dee85e3ef27e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,25 @@
# Author: horst3180 @ deviantart
pkgname=vertex-themes
-pkgver=20161009
+pkgver=20170128
pkgrel=1
pkgdesc='Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.22 version)'
_gnomever=3.22
+_releasever=20170128
arch=('any')
url='http://horst3180.deviantart.com/art/Vertex-Theme-470663601'
license=('GPL3')
depends=('gtk-engine-murrine')
-makedepends=('git')
conflicts=('vertex-themes-git')
-source=($pkgname::git+https://github.com/horst3180/Vertex-theme.git#commit=c861918a7fccf6d0768d45d790a19a13bb23485e)
-sha256sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- # get number of last git commit
- _commitCount=$(git rev-list --count HEAD)
- # get time of last git commit
- _commitTime=$(git show -s --format="%ci" | grep -o "....-..-.." | sed "s/-//g")
- # add "r*.*" from package version
- #echo "r$_commitCount.$_commitTime"
- echo "$_commitTime"
-}
+source=("${pkgname}-${_releasever}.tar.gz::https://github.com/horst3180/Vertex-theme/archive/${_releasever}.tar.gz")
+sha256sums=('1540657ff247bcdb9c49a740e4ddf305aecd4f3bebc93ca566fe74d319b7a620')
build() {
- cd $pkgname
-
+ cd vertex-theme-${_releasever}
./autogen.sh --prefix=/usr --with-gnome=${_gnomever}
}
package() {
- cd $pkgname
+ cd vertex-theme-${_releasever}
make DESTDIR="$pkgdir" install
cd extra