summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCanalGuada2015-06-09 02:58:05 +0200
committerCanalGuada2015-06-09 02:58:05 +0200
commit44984d3239733b93302c34f7f3608da63ca4a909 (patch)
tree68ee446a12567a88a5312c01a353146ee6fa46c5
downloadaur-44984d3239733b93302c34f7f3608da63ca4a909.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8807758bfe0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vertex-themes-git
+ pkgdesc = Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.16 version)
+ pkgver = r498.20150425
+ pkgrel = 1
+ url = http://horst3180.deviantart.com/art/Vertex-Theme-470663601
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-engine-murrine
+ provides = vertex-themes
+ conflicts = vertex-themes
+ source = vertex-themes-git::git+https://github.com/horst3180/Vertex-theme.git
+ sha256sums = SKIP
+
+pkgname = vertex-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..306f77c450ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: CanalGuada <dguadal at free dot fr>
+# Author: horst3180 @ deviantart
+
+pkgname=vertex-themes-git
+pkgver=r498.20150425
+pkgrel=1
+pkgdesc='Vertex Gtk2, Gtk3, Metacity, Xfwm, Cinnamon and GNOME Shell themes (GNOME 3.16 version)'
+_gnomever=3.16
+arch=('any')
+url='http://horst3180.deviantart.com/art/Vertex-Theme-470663601'
+license=('GPL3')
+depends=('gtk-engine-murrine')
+makedepends=('git')
+provides=('vertex-themes')
+conflicts=('vertex-themes')
+source=($pkgname::git+https://github.com/horst3180/Vertex-theme.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ # get number of last git commit
+ _commitCount=$(git rev-list --count HEAD)
+ # get time of last git commit
+ _commitTime=$(git show -s --format="%ci" | grep -o "....-..-.." | sed "s/-//g")
+ # add "r*.*" from package version
+ echo "r$_commitCount.$_commitTime"
+}
+
+build() {
+ cd $pkgname
+
+ ./autogen.sh --prefix=/usr --with-gnome=${_gnomever}
+}
+package() {
+ cd $pkgname
+
+ make DESTDIR="$pkgdir" install
+ cd extra
+ for name in "Chrome" "Firefox" "Vertex-Plank" "Vertex_alt_metacity"; do
+ find "$name" -type f -not -name *~ -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
+ done
+
+ cd ..
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 README.md "$pkgdir/usr/share/themes/Vertex/README"
+}
+
+# vim: ts=2 sw=2 et: