summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaspar Friedrich2015-06-28 23:19:36 +0200
committerCaspar Friedrich2015-06-28 23:19:36 +0200
commitd2b89556995cde1ca5a00fd8b9e0986e1b61c907 (patch)
treea5beabde3966b301e8f0006d253953ebf9383551
downloadaur-d2b89556995cde1ca5a00fd8b9e0986e1b61c907.tar.gz
Update to 3.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c326bf94e89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vertx
+ pkgdesc = Effortless asynchronous application development for the modern web and enterprise
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://vertx.io
+ arch = any
+ license = APACHE
+ depends = java-environment>=7
+ source = https://bintray.com/artifact/download/vertx/downloads/vert.x-3.0.0-full.tar.gz
+ sha1sums = 47b0fad8de3e9c175fca9ff70a127facdd0c0cf0
+
+pkgname = vertx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..302d169ab79e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caspar Friedrich <c.s.w.friedrich@gmail.com>
+
+pkgname=vertx
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Effortless asynchronous application development for the modern web and enterprise"
+arch=(any)
+url="http://vertx.io"
+license=("APACHE")
+depends=("java-environment>=7")
+
+source=("https://bintray.com/artifact/download/vertx/downloads/vert.x-${pkgver}-full.tar.gz")
+sha1sums=("47b0fad8de3e9c175fca9ff70a127facdd0c0cf0")
+
+package() {
+ install -d -m 755 ${pkgdir}/opt
+ mv ${srcdir}/vert.x-${pkgver}/ ${pkgdir}/opt/vertx
+
+ install -d -m 755 ${pkgdir}/usr/bin
+ ln -s /opt/vertx/bin/vertx ${pkgdir}/usr/bin
+}