summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat Bakarov2023-03-03 10:10:02 +0700
committerAskhat Bakarov2023-03-03 10:10:02 +0700
commit87571460ae8eeed72c43ffe83d11d306824eff8e (patch)
treee3875f3ad73c5ef325f99afcfe2c81b5e49a9fc9
parent859a23daba6ee8f4f220b6ee25011892b73d657c (diff)
downloadaur-veusz.tar.gz
Updated to version 3.6.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf086b7de42c..7f3dca263259 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = veusz
pkgdesc = A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output
- pkgver = 3.5.3
- pkgrel = 2
+ pkgver = 3.6.2
+ pkgrel = 1
url = https://veusz.github.io/
arch = x86_64
license = GPL2
makedepends = sip>=6.7.5
- makedepends = python-tomli
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-pyqt5
depends = python-numpy
depends = hicolor-icon-theme
@@ -16,7 +18,7 @@ pkgbase = veusz
optdepends = python-iminuit: improved fitting
optdepends = python-astropy: VO table import and FITS import
optdepends = ghostscript: for EPS/PS output
- source = https://github.com/veusz/veusz/releases/download/veusz-3.5.3/veusz-3.5.3.tar.gz
- sha256sums = d4c3c29a4d314a97d7ec25cf154e381df3c8f5910a94e1bd993e7ba1c4d69473
+ source = https://github.com/veusz/veusz/releases/download/veusz-3.6.2/veusz-3.6.2.tar.gz
+ sha256sums = c2171ac45e4b30424d8fc35261e2e99dbe6e25ba1197ebc24355b106b26395d1
pkgname = veusz
diff --git a/PKGBUILD b/PKGBUILD
index 1840f7fedbe9..375fec251a16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
# Contributor: moostik <mooostik_at_gmail.com>
pkgname=veusz
-pkgver=3.5.3
-pkgrel=2
+pkgver=3.6.2
+pkgrel=1
pkgdesc="A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output"
arch=('x86_64')
url="https://veusz.github.io/"
license=('GPL2')
depends=('python-pyqt5' 'python-numpy' 'hicolor-icon-theme')
-makedepends=('sip>=6.7.5' 'python-tomli')
+makedepends=('sip>=6.7.5' 'python-build' 'python-installer' 'python-wheel')
optdepends=('python-h5py: HDF5 support'
'python-pyemf3: EMF export'
'python-dbus: dbus interface'
@@ -20,17 +20,17 @@ optdepends=('python-h5py: HDF5 support'
'python-astropy: VO table import and FITS import'
'ghostscript: for EPS/PS output')
source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz")
-sha256sums=('d4c3c29a4d314a97d7ec25cf154e381df3c8f5910a94e1bd993e7ba1c4d69473')
+sha256sums=('c2171ac45e4b30424d8fc35261e2e99dbe6e25ba1197ebc24355b106b26395d1')
build() {
cd "${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
for _i in 16 32 48 64 128; do
install -D -m644 "icons/veusz_${_i}.png" \
"${pkgdir}/usr/share/icons/hicolor/${_i}x${_i}/apps/veusz.png"