summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat2018-06-12 21:48:00 +0700
committerAskhat2018-06-12 21:48:00 +0700
commitb1337b96af91cd2e104d7ac23804c770ec9f9b45 (patch)
treee2ef740a4df6783d73584bacdcb686241f8962ca
parent4215278a37005c0c9e55080766563f863863a252 (diff)
downloadaur-b1337b96af91cd2e104d7ac23804c770ec9f9b45.tar.gz
Updated to 3.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cc637caba40..4926ff59cde6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
# Generated by mksrcinfo v8
-# Wed Apr 18 15:44:44 UTC 2018
+# Tue Jun 12 14:47:05 UTC 2018
pkgbase = veusz
- pkgdesc = A scientific plotting and graphing package, designed to create publication-ready PDF or SVG output
- pkgver = 2.2.2
+ pkgdesc = A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output
+ pkgver = 3.0
pkgrel = 1
url = https://veusz.github.io/
arch = x86_64
license = GPL2
depends = python-pyqt5
depends = python-numpy
+ depends = python-sip
depends = hicolor-icon-theme
- optdepends = python-pyfits: for reading files in FITS format
- optdepends = python-dbus: for dbus interface
- optdepends = python-iminuit: for numerical function minimization
- optdepends = python-astropy: for VO table import
- source = https://github.com/veusz/veusz/releases/download/veusz-2.2.2/veusz-2.2.2.tar.gz
- sha256sums = d630553f8531e9442d2d8077d0c79287760de52804fb13c342512384e77546c2
+ optdepends = python-h5py: HDF5 support
+ optdepends = python-dbus: dbus interface
+ optdepends = python-iminuit: improved fitting
+ optdepends = python-astropy: VO table import and FITS import
+ optdepends = ghostscript: for EPS/PS output
+ source = https://github.com/veusz/veusz/releases/download/veusz-3.0/veusz-3.0.tar.gz
+ sha256sums = 24189cbd46d341b0853a70ced2b80ab9e1efd5cfaf201283ce2ccde1c2937407
pkgname = veusz
diff --git a/PKGBUILD b/PKGBUILD
index 2de88f2e7178..4e183413d62e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,21 @@
# Contributor: moostik <mooostik_at_gmail.com>
pkgname=veusz
-pkgver=2.2.2
+pkgver=3.0
pkgrel=1
-pkgdesc="A scientific plotting and graphing package, designed to create publication-ready PDF or SVG output"
+pkgdesc="A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output"
arch=('x86_64')
url="https://veusz.github.io/"
license=('GPL2')
-depends=('python-pyqt5' 'python-numpy' 'hicolor-icon-theme')
-optdepends=('python-pyfits: for reading files in FITS format'
-# 'python-emf: for EMF export' - http://pyemf.sourceforge.net/ - package missing
- 'python-dbus: for dbus interface'
- 'python-iminuit: for numerical function minimization'
- 'python-astropy: for VO table import')
+depends=('python-pyqt5' 'python-numpy' 'python-sip' 'hicolor-icon-theme')
+optdepends=('python-h5py: HDF5 support'
+# 'pyemf >= 2.0.0: EMF export https://github.com/jeremysanders/pyemf (Python 3 port in development) - package missing
+ 'python-dbus: dbus interface'
+ 'python-iminuit: improved fitting'
+ 'python-astropy: VO table import and FITS import'
+ 'ghostscript: for EPS/PS output')
source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz")
-sha256sums=('d630553f8531e9442d2d8077d0c79287760de52804fb13c342512384e77546c2')
+sha256sums=('24189cbd46d341b0853a70ced2b80ab9e1efd5cfaf201283ce2ccde1c2937407')
build() {
cd "${pkgname}-${pkgver}"