summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat2020-12-08 21:03:48 +0700
committerAskhat2020-12-08 21:03:48 +0700
commitfda879dacee4a5f805dec621ee5effb24f1fd8fc (patch)
tree819c216366612230fe1e4d6b6a2159bb36c0a3dc
parent8cb5ac6654b41ca0965807613574e3fad877f19a (diff)
downloadaur-fda879dacee4a5f805dec621ee5effb24f1fd8fc.tar.gz
Updated to version 3.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--veusz-3.2.1-sip_dir.patch12
3 files changed, 12 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86fcba21ca93..c07c61938844 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = veusz
pkgdesc = A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output
- pkgver = 3.2.1
+ pkgver = 3.3.1
pkgrel = 1
url = https://veusz.github.io/
arch = x86_64
license = GPL2
- makedepends = sip
+ makedepends = sip5
depends = python-pyqt5
depends = python-numpy
depends = python-sip
@@ -15,10 +15,8 @@ pkgbase = veusz
optdepends = python-iminuit: improved fitting
optdepends = python-astropy: VO table import and FITS import
optdepends = ghostscript: for EPS/PS output
- source = https://github.com/veusz/veusz/releases/download/veusz-3.2.1/veusz-3.2.1.tar.gz
- source = veusz-3.2.1-sip_dir.patch
- sha256sums = 9eaf95a2a8cae2d317e7ee47e73f5cf58d191b16c051ae0a1dc399e6f7757503
- sha256sums = 334700cb64638fb4710e3049fe26d7b97abafc24581ad949b110e5d07567d31f
+ source = https://github.com/veusz/veusz/releases/download/veusz-3.3.1/veusz-3.3.1.tar.gz
+ sha256sums = e02960630894db5c070ef7b6abd708b520156fd85b47617e7c973cce7188f0e0
pkgname = veusz
diff --git a/PKGBUILD b/PKGBUILD
index 5e62b3fe6b53..497274ccf26d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,30 @@
# Contributor: moostik <mooostik_at_gmail.com>
pkgname=veusz
-pkgver=3.2.1
+pkgver=3.3.1
pkgrel=1
pkgdesc="A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output"
arch=('x86_64')
url="https://veusz.github.io/"
license=('GPL2')
depends=('python-pyqt5' 'python-numpy' 'python-sip' 'hicolor-icon-theme')
-makedepends=('sip')
+makedepends=('sip5')
optdepends=('python-h5py: HDF5 support'
# 'pyemf >= 2.0.0: EMF export https://github.com/jeremysanders/pyemf (Python 3 port in development) - package missing
'python-dbus: dbus interface'
'python-iminuit: improved fitting'
'python-astropy: VO table import and FITS import'
'ghostscript: for EPS/PS output')
- # patch from https://github.com/veusz/veusz/issues/307
-source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz"
- "veusz-${pkgver}-sip_dir.patch")
-sha256sums=('9eaf95a2a8cae2d317e7ee47e73f5cf58d191b16c051ae0a1dc399e6f7757503'
- '334700cb64638fb4710e3049fe26d7b97abafc24581ad949b110e5d07567d31f')
+source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz")
+sha256sums=('e02960630894db5c070ef7b6abd708b520156fd85b47617e7c973cce7188f0e0')
-prepare() {
- patch -Np1 -i "veusz-${pkgver}-sip_dir.patch"
-}
build() {
cd "${pkgname}-${pkgver}"
- python setup.py build_ext --sip-dir=/usr/lib/python3.8/site-packages/PyQt5/bindings/
+ [[ -d NEW ]] || mkdir -p NEW
+ [[ -d NEW/PyQt5 ]] && rm -rf NEW/PyQt5
+ ln -s /usr/lib/python3.9/site-packages/PyQt5/bindings/ NEW/PyQt5
+ export SIP_DIR=NEW/
python setup.py build
}
diff --git a/veusz-3.2.1-sip_dir.patch b/veusz-3.2.1-sip_dir.patch
deleted file mode 100644
index 0e93bcaaf6a7..000000000000
--- a/veusz-3.2.1-sip_dir.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nuar src/veusz-3.2.1/pyqtdistutils.py src/veusz-3.2.1.patched/pyqtdistutils.py
---- src/veusz-3.2.1/pyqtdistutils.py 2020-01-26 18:25:09.000000000 +0700
-+++ src/veusz-3.2.1patched/pyqtdistutils.py 2020-03-10 12:14:02.317395029 +0700
-@@ -310,7 +310,7 @@
- sip_exe,
- '-c', self.build_temp
- ] + SIP_FLAGS.split() + [
-- '-I', os.path.join(sip_dir, 'PyQt5'),
-+ '-I', sip_dir,
- '-b', sbf,
- source
- ]