summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-26 09:52:28 +0800
committerzxp198210052023-06-26 09:52:28 +0800
commite0775a6418f5e753b3c2ec9edee4f24405dfb8e8 (patch)
treeee826af13044100fdeba765c75db62cebbfc2fcf
parente64f09b25d5abdebf73b9141c80f2862204bd652 (diff)
downloadaur-e0775a6418f5e753b3c2ec9edee4f24405dfb8e8.tar.gz
fix errors
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD31
2 files changed, 32 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb95d041bf48..6fac2be3a1ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,33 @@
pkgbase = veyon-bin
pkgdesc = Cross-platform computer monitoring and classroom management
pkgver = 4.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://veyon.io/
arch = x86_64
license = GPL2
- depends = hicolor-icon-theme
- depends = libfakekey
- depends = libldap
- depends = libsasl
- depends = libvncserver
- depends = libxcomposite
- depends = libxdamage
+ depends = procps-ng
+ depends = libjpeg6-turbo
+ depends = glibc
+ depends = pam
depends = libxext
- depends = libxfixes
- depends = libxinerama
depends = libxrandr
+ depends = libx11
+ depends = lzo
+ depends = libpng
depends = libxtst
- depends = pam
- depends = procps-ng
- depends = qca-qt5
+ depends = zlib
+ depends = hicolor-icon-theme
+ depends = openssl-1.1
+ depends = gcc-libs
+ depends = libxdamage
+ depends = qt5-base
+ depends = libxinerama
+ depends = libxfixes
+ depends = libxcomposite
+ depends = libxi
provides = veyon
conflicts = veyon
- noextract = veyon-4.8.0.0-fedora.37.x86_64.rpm
- source = https://github.com/veyon/veyon/releases/download/v4.8.0/veyon-4.8.0.0-fedora.37.x86_64.rpm
- sha256sums = 03b9880b958aa10462e4064ab4d415cebb6b84f5421c34fc04eb78e4a24abbe1
+ source = veyon-4.8.0.deb::https://github.com/veyon/veyon/releases/download/v4.8.0/veyon_4.8.0.0-debian.bullseye_amd64.deb
+ sha256sums = 6357342fc66e02e51f9d76ce72ccee5d37dd1f83e408cbd739712a7b5c9d2b1e
pkgname = veyon-bin
diff --git a/PKGBUILD b/PKGBUILD
index 389194f513af..6709f9581a1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,22 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=veyon-bin
pkgver=4.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-platform computer monitoring and classroom management"
arch=('x86_64')
url="https://veyon.io/"
+_githuburl="https://github.com/veyon/veyon"
license=('GPL2')
-depends=('hicolor-icon-theme' 'libfakekey' 'libldap' 'libsasl' 'libvncserver'
- 'libxcomposite' 'libxdamage' 'libxext' 'libxfixes' 'libxinerama'
- 'libxrandr' 'libxtst' 'pam' 'procps-ng' 'qca-qt5')
+depends=('procps-ng' 'libjpeg6-turbo' 'glibc' 'pam' 'libxext' 'libxrandr' 'libx11' 'lzo' 'libpng' 'libxtst' 'zlib' \
+ 'hicolor-icon-theme' 'openssl-1.1' 'gcc-libs' 'libxdamage' 'qt5-base' 'libxinerama' 'libxfixes' 'libxcomposite' 'libxi')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-source=("https://github.com/veyon/veyon/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}.0-fedora.37.x86_64.rpm")
-noextract=("${pkgname%-bin}-${pkgver}.0-fedora.37.x86_64.rpm")
-sha256sums=('03b9880b958aa10462e4064ab4d415cebb6b84f5421c34fc04eb78e4a24abbe1')
-
-prepare() {
- mkdir -p "${pkgname%-bin}-${pkgver}"
- bsdtar -xvf "${pkgname%-bin}-${pkgver}.0-fedora.37.x86_64.rpm" -C "${pkgname%-bin}-${pkgver}"
-}
-
+source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}.0-debian.bullseye_amd64.deb")
+sha256sums=('6357342fc66e02e51f9d76ce72ccee5d37dd1f83e408cbd739712a7b5c9d2b1e')
package() {
- cd "${pkgname%-bin}-${pkgver}"
- install -Dm755 usr/bin/* -t "${pkgdir}/usr/bin/"
- install -d "${pkgdir}/usr/lib"
- cp -r lib/systemd "usr/lib64/${pkgname%-bin}" "${pkgdir}/usr/lib/"
- cp -r usr/share "${pkgdir}/usr/"
-}
+ bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ mv "${pkgdir}/usr/lib/x86_64-linux-gnu/${pkgname%-bin}" "${pkgdir}/usr/lib"
+ install -Dm755 "${pkgdir}/lib/systemd/system/${pkgname%-bin}.service" -t "${pkgdir}/usr/lib/systemd/user"
+ rm -rf "${pkgdir}/usr/lib/x86_64-linux-gnu" "${pkgdir}/lib"
+ chmod 0755 "${pkgdir}/usr/bin/veyon-auth-helper"
+} \ No newline at end of file