summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-04-21 08:34:04 -0600
committerMark Wagie2023-04-21 08:34:04 -0600
commite64f09b25d5abdebf73b9141c80f2862204bd652 (patch)
tree635da0b43ba95cadcbf19db401eddd7eb8d35f9d
parent059b5832d442108b4c1dff7a70d0c86b78e57626 (diff)
downloadaur-e64f09b25d5abdebf73b9141c80f2862204bd652.tar.gz
4.8.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD13
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df37bfda579c..eb95d041bf48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = veyon-bin
pkgdesc = Cross-platform computer monitoring and classroom management
- pkgver = 4.7.5
+ pkgver = 4.8.0
pkgrel = 1
url = https://veyon.io/
arch = x86_64
@@ -10,12 +10,6 @@ pkgbase = veyon-bin
depends = libldap
depends = libsasl
depends = libvncserver
- depends = libxi
- depends = qt5-base
- depends = libx11
- depends = glibc
- depends = openssl
- depends = libxcursor
depends = libxcomposite
depends = libxdamage
depends = libxext
@@ -26,11 +20,10 @@ pkgbase = veyon-bin
depends = pam
depends = procps-ng
depends = qca-qt5
- depends = gcc-libs
provides = veyon
conflicts = veyon
- noextract = veyon-4.7.5.0-fedora.37.x86_64.rpm
- source = https://github.com/veyon/veyon/releases/download/v4.7.5/veyon-4.7.5.0-fedora.37.x86_64.rpm
- sha256sums = c5b429913bb2b2fe327cd8b2ca75c2a198a48afe78e148da0209408dd81f3a97
+ noextract = veyon-4.8.0.0-fedora.37.x86_64.rpm
+ source = https://github.com/veyon/veyon/releases/download/v4.8.0/veyon-4.8.0.0-fedora.37.x86_64.rpm
+ sha256sums = 03b9880b958aa10462e4064ab4d415cebb6b84f5421c34fc04eb78e4a24abbe1
pkgname = veyon-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index ef78142f812a..389194f513af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-# Maintainer: yochananmarqos <mark dot wagie at proton dot me>
+# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=veyon-bin
-pkgver=4.7.5
+pkgver=4.8.0
pkgrel=1
pkgdesc="Cross-platform computer monitoring and classroom management"
arch=('x86_64')
url="https://veyon.io/"
license=('GPL2')
-depends=('hicolor-icon-theme' 'libfakekey' 'libldap' 'libsasl' 'libvncserver' 'libxi' 'qt5-base' 'libx11' 'glibc' 'openssl' 'libxcursor' \
- 'libxcomposite' 'libxdamage' 'libxext' 'libxfixes' 'libxinerama' 'libxrandr' 'libxtst' 'pam' 'procps-ng' 'qca-qt5' 'gcc-libs')
+depends=('hicolor-icon-theme' 'libfakekey' 'libldap' 'libsasl' 'libvncserver'
+ 'libxcomposite' 'libxdamage' 'libxext' 'libxfixes' 'libxinerama'
+ 'libxrandr' 'libxtst' 'pam' 'procps-ng' 'qca-qt5')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
source=("https://github.com/veyon/veyon/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}.0-fedora.37.x86_64.rpm")
noextract=("${pkgname%-bin}-${pkgver}.0-fedora.37.x86_64.rpm")
-sha256sums=('c5b429913bb2b2fe327cd8b2ca75c2a198a48afe78e148da0209408dd81f3a97')
+sha256sums=('03b9880b958aa10462e4064ab4d415cebb6b84f5421c34fc04eb78e4a24abbe1')
prepare() {
mkdir -p "${pkgname%-bin}-${pkgver}"
@@ -26,4 +27,4 @@ package() {
install -d "${pkgdir}/usr/lib"
cp -r lib/systemd "usr/lib64/${pkgname%-bin}" "${pkgdir}/usr/lib/"
cp -r usr/share "${pkgdir}/usr/"
-} \ No newline at end of file
+}