summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schrodt2020-05-24 17:13:36 +0200
committerMartin Schrodt2020-05-24 17:13:36 +0200
commit651b250f38a865d96d27f4d1ad55f0a6f131d4d7 (patch)
tree311e8bce30ce0ece66186a3697fb3f266f7f5b02
parent6106c76b29008526944732861ef20842771a188c (diff)
downloadaur-651b250f38a865d96d27f4d1ad55f0a6f131d4d7.tar.gz
try fixing generation of completion script
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55150ef38cc4..50243b2af2f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vfio-isolate
pkgdesc = commandline tool to facilitate CPU core isolation
- pkgver = 0.2.1
+ pkgver = 0.2.2
pkgrel = 1
url = https://pypi.org/project/vfio-isolate
arch = any
@@ -10,8 +10,8 @@ pkgbase = vfio-isolate
depends = python-click
depends = python-psutil
depends = python-parsimonious
- source = https://files.pythonhosted.org/packages/source/v/vfio-isolate/vfio-isolate-0.2.1.tar.gz
- md5sums = 2a6e1085fd51c90c5228417ff46e04c5
+ source = https://files.pythonhosted.org/packages/source/v/vfio-isolate/vfio-isolate-0.2.2.tar.gz
+ md5sums = 9897c424ac9034e8a03b1ad980853750
pkgname = vfio-isolate
diff --git a/PKGBUILD b/PKGBUILD
index 38c6a43e0106..aea2bba327b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Schrodt <martin@schrodt.org>
pkgname=vfio-isolate
-pkgver=0.2.1
+pkgver=0.2.2
pkgrel=1
pkgdesc="commandline tool to facilitate CPU core isolation"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ makedepends=('python-setuptools')
license=('unknown')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('2a6e1085fd51c90c5228417ff46e04c5')
+md5sums=('9897c424ac9034e8a03b1ad980853750')
build() {
cd "$pkgname-$pkgver"
@@ -23,5 +23,5 @@ package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
mkdir -p "$pkgdir/usr/share/zsh/site-functions"
- _VFIO_ISOLATE_COMPLETE=source_zsh "$pkgdir/usr/bin/vfio-isolate" > "$pkgdir/usr/share/zsh/site-functions/_vfio-isolate" || true
+ _VFIO_ISOLATE_COMPLETE=source_zsh python "$pkgdir/usr/lib/python3.8/site-packages/vfio_isolate/cli.py" > "$pkgdir/usr/share/zsh/site-functions/_vfio-isolate" || true
}