summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schrodt2021-08-18 18:06:07 +0200
committerMartin Schrodt2021-08-18 18:06:07 +0200
commit65ceda5f549545cd78c43472cd39332b84fb9884 (patch)
treedae0930eebc3cc01eacd1538fd3933704f66cf6a
parent74a4788d1882c9600d284674e0354313616e9b3d (diff)
downloadaur-65ceda5f549545cd78c43472cd39332b84fb9884.tar.gz
v 0.4.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dce0f616fcd..07f4332687ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vfio-isolate
pkgdesc = commandline tool to facilitate CPU core isolation
- pkgver = 0.3.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://pypi.org/project/vfio-isolate
arch = any
@@ -10,8 +10,7 @@ pkgbase = vfio-isolate
depends = python-click
depends = python-psutil
depends = python-parsimonious
- source = https://files.pythonhosted.org/packages/source/v/vfio-isolate/vfio-isolate-0.3.1.tar.gz
- md5sums = 6ce1d98928a18675039d9322fae27091
+ source = https://files.pythonhosted.org/packages/source/v/vfio-isolate/vfio-isolate-0.4.0.tar.gz
+ md5sums = 78ecc44526d68ebf9fefade84d99e413
pkgname = vfio-isolate
-
diff --git a/PKGBUILD b/PKGBUILD
index d140cd97b04b..8cc28d5dbd5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Schrodt <martin@schrodt.org>
pkgname=vfio-isolate
-pkgver=0.3.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="commandline tool to facilitate CPU core isolation"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ makedepends=('python-setuptools')
license=('unknown')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('6ce1d98928a18675039d9322fae27091')
+md5sums=('78ecc44526d68ebf9fefade84d99e413')
build() {
cd "$pkgname-$pkgver"
@@ -23,7 +23,7 @@ package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
mkdir -p "$pkgdir/usr/share/zsh/site-functions"
- _VFIO_ISOLATE_COMPLETE=source_zsh python "$pkgdir/usr/lib/python3.8/site-packages/vfio_isolate/cli.py" > "$pkgdir/usr/share/zsh/site-functions/_vfio-isolate" || true
+ _VFIO_ISOLATE_COMPLETE=source_zsh python "$pkgdir/usr/lib/python3.9/site-packages/vfio_isolate/cli.py" > "$pkgdir/usr/share/zsh/site-functions/_vfio-isolate" || true
mkdir -p "$pkgdir/usr/share/bash-completion/completions"
- _VFIO_ISOLATE_COMPLETE=source_bash python "$pkgdir/usr/lib/python3.8/site-packages/vfio_isolate/cli.py" > "$pkgdir/usr/share/bash-completion/completions/vfio-isolate" || true
+ _VFIO_ISOLATE_COMPLETE=source_bash python "$pkgdir/usr/lib/python3.9/site-packages/vfio_isolate/cli.py" > "$pkgdir/usr/share/bash-completion/completions/vfio-isolate" || true
}