aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandy59952022-08-10 21:53:46 -0500
committerandy59952022-08-10 21:53:46 -0500
commitd8b700876957af3ff44d24471eefe6ae06cd81e4 (patch)
treee0bec4d9f3073af7e82904db2fb8a4d45ed2edf1
parent262f0530f21253de99b0b0e8be8531fb7796fe9a (diff)
downloadaur-d8b700876957af3ff44d24471eefe6ae06cd81e4.tar.gz
4.23-2:add fix for pcre2/parallel build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 234a54b40fc5..2d8fecec20e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vfu
pkgdesc = Versatile text-based file-manager
pkgver = 4.23
- pkgrel = 1
+ pkgrel = 2
url = http://cade.noxrun.com/projects/vfu
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = vfu
arch = ppc64le
license = GPL
depends = ncurses
+ depends = pcre2
optdepends = perl: for the rx_* archiving utilities
optdepends = rpmextract: for rx_rpm
optdepends = unrar: for rx_rar
diff --git a/PKGBUILD b/PKGBUILD
index 5fda764be073..606d551ae251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=vfu
pkgver=4.23
-pkgrel=1
+pkgrel=2
pkgdesc="Versatile text-based file-manager"
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'ppc64le')
url="http://cade.noxrun.com/projects/vfu"
license=('GPL')
-depends=('ncurses')
+depends=('ncurses' 'pcre2')
optdepends=('perl: for the rx_* archiving utilities'
'rpmextract: for rx_rpm'
'unrar: for rx_rar'
@@ -19,7 +19,8 @@ sha256sums=('cb118813fd9b629731e96d70098319193b3415aa60e796596bacc6c482960779')
build() {
cd "$srcdir/$pkgname-$pkgver"
-
+ cp ../../pcre2_parallel.patch .
+ patch -p1 < pcre2_parallel.patch
make CCDEF="$CFLAGS -D_FILE_OFFSET_BITS=64"
./build.docs
}