summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-15 19:31:04 +0300
committerDimitris Kiziridis2020-05-15 19:31:04 +0300
commit761339128a7a64d87b643a4a3f3590823e01646e (patch)
tree1a147d3890317c195b473e8b00b278607cb00117
parent1de098df69a3cfcabb2852954a209f7cc9bcc174 (diff)
downloadaur-761339128a7a64d87b643a4a3f3590823e01646e.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d1ebc54697..48f7c3dbd6af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,12 @@ pkgbase = vg-bin
url = https://github.com/GetStream/vg
arch = x86_64
license = MIT
+ depends = glibc
provides = vg
- source = https://github.com/GetStream/vg/releases/download/v0.9.0/vg-linux-amd64
- md5sums = dc968a20d16aca3de752a217e97094a2
+ source = vg-bin-0.9.0::https://github.com/GetStream/vg/releases/download/v0.9.0/vg-linux-amd64
+ source = LICENSE::https://github.com/GetStream/vg/raw/master/LICENSE
+ sha256sums = 9e9ef148ec723b3d1c0d737ed49222409325c9f801aebd9d2bb9dc02a1e3a651
+ sha256sums = 9c90e4c371a644b6968d97d5aaec69d6ebb922ea986b9b17ce58e2afb2fa2d12
pkgname = vg-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3312b9b6b047..da4292b5ce66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,14 @@ arch=('x86_64')
url="https://github.com/GetStream/vg"
license=('MIT')
provides=('vg')
-source=("${url}/releases/download/v${pkgver}/vg-linux-amd64")
-md5sums=('dc968a20d16aca3de752a217e97094a2')
+depends=('glibc')
+source=("${pkgname}-${pkgver}::${url}/releases/download/v${pkgver}/vg-linux-amd64"
+ 'LICENSE::https://github.com/GetStream/vg/raw/master/LICENSE')
+sha256sums=('9e9ef148ec723b3d1c0d737ed49222409325c9f801aebd9d2bb9dc02a1e3a651'
+ '9c90e4c371a644b6968d97d5aaec69d6ebb922ea986b9b17ce58e2afb2fa2d12')
package() {
install -Dm755 "${srcdir}"/vg-* "${pkgdir}/usr/bin/vg"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file