summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Lin2016-05-22 01:34:02 -0700
committerAndrew Lin2016-05-22 01:51:59 -0700
commit285a4299639c01a47c1c60d589bc7977f0cba674 (patch)
treec41e2586c0a7097bab3b0158130ff102f644a580
downloadaur-285a4299639c01a47c1c60d589bc7977f0cba674.tar.gz
Initial package for release 0.40.7
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ec3299fc973
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vgmplay
+ pkgdesc = The offical and always up-to-date player for all VGM files
+ pkgver = 0.40.7
+ pkgrel = 1
+ url = http://vgmrips.net/forum/viewtopic.php?t=112
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = libao
+ depends = zlib
+ source = https://github.com/vgmrips/vgmplay/archive/0.40.7.tar.gz
+ md5sums = 90445783677eef5068a8aca338368dc5
+
+pkgname = vgmplay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0936acc49257
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Andrew Lin <andrewlin16@gmail.com>
+
+pkgname=vgmplay
+pkgver=0.40.7
+pkgrel=1
+pkgdesc="The offical and always up-to-date player for all VGM files"
+arch=('i686' 'x86_64')
+url="http://vgmrips.net/forum/viewtopic.php?t=112"
+license=('GPL' 'custom')
+source=("https://github.com/vgmrips/vgmplay/archive/$pkgver.tar.gz")
+depends=('libao' 'zlib')
+md5sums=('90445783677eef5068a8aca338368dc5')
+
+build() {
+ cd "$pkgname-$pkgver/VGMPlay"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/VGMPlay"
+ mkdir -m 755 -p "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ make PREFIX=/usr DESTDIR="$pkgdir" play_inst
+ mkdir -m 755 -p "$pkgdir/usr/share/licenses/vgmplay"
+ cp licenses/* "$pkgdir/usr/share/licenses/vgmplay"
+}
+
+# vim:set ts=2 sw=2 et: