summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Lin2021-03-27 03:39:47 -0700
committerAndrew Lin2021-03-27 03:39:47 -0700
commit5f1533c4f352409cd0fbd58994c1c1afee295e87 (patch)
tree83a5ff7a2a6852f322fd2b87fd3e28068efd77db
downloadaur-5f1533c4f352409cd0fbd58994c1c1afee295e87.tar.gz
Create initial PKGBUILD for vgmplay-libvgm-git
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f5a073e0f08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = vgmplay-libvgm-git
+ pkgdesc = A new VGMPlay, based on libvgm
+ pkgver = 0.50.1.r24.g6480d3e
+ pkgrel = 1
+ url = https://github.com/ValleyBell/vgmplay-libvgm
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = libvgm-player-git
+ depends = libvgm-emu-git
+ depends = libvgm-utils-git
+ depends = libvgm-audio-git
+ conflicts = vgmplay
+ source = git://github.com/ValleyBell/vgmplay-libvgm.git
+ source = git://github.com/benhoyt/inih.git
+ source = git://github.com/alex85k/wingetopt.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = vgmplay-libvgm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba126a3ebf4c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95b118e97b1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Andrew Lin <andrewlin16@gmail.com>
+
+pkgname=vgmplay-libvgm-git
+pkgver=0.50.1.r24.g6480d3e
+pkgrel=1
+pkgdesc="A new VGMPlay, based on libvgm"
+arch=('x86_64')
+url="https://github.com/ValleyBell/vgmplay-libvgm"
+license=('GPL')
+source=(
+ "git://github.com/ValleyBell/vgmplay-libvgm.git"
+ "git://github.com/benhoyt/inih.git"
+ "git://github.com/alex85k/wingetopt.git"
+)
+depends=('libvgm-player-git' 'libvgm-emu-git' 'libvgm-utils-git' 'libvgm-audio-git')
+makedepends=('cmake' 'git')
+conflicts=('vgmplay')
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ git submodule init
+ git config submodule.inih.url "$srcdir/inih"
+ git config submodule.wingetopt.url "$srcdir/wingetopt"
+ git submodule update
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cmake .
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -d -m755 "$pkgdir/usr/bin"
+ install -m755 vgmplay "$pkgdir/usr/bin/vgmplay"
+ install -d -m755 "$pkgdir/usr/share/vgmplay"
+ install -m644 VGMPlay.ini "$pkgdir/usr/share/vgmplay/VGMPlay.ini"
+}
+
+# vim:set ts=2 sw=2 et: