summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatti Niemenmaa2017-09-07 23:40:18 +0300
committerMatti Niemenmaa2017-09-07 23:40:18 +0300
commita91006e7fe44297dd72c937d74abfb10d84e963f (patch)
tree5ce690e03aa07f2cf542bb5941410507c4a4f569
parentc61f32d5cac660e825b2ed20b2afc409df8c6de8 (diff)
downloadaur-a91006e7fe44297dd72c937d74abfb10d84e963f.tar.gz
Fix build after various changes
* Makefile patch no longer applies, and is not needed. * Patch configure.ac instead of configure.in. * clHCA.h is #included from outside vgmstream/, so install it at the root of /usr/include. * Makefiles were renamed from *.unix to *.audacious. Misleading for this, since we don't actually provide the Audacious plugin. * ffmpeg is now needed due to VGM_USE_FFMPEG, which is theoretically optional, but the code does not compile without it.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
-rw-r--r--libcoding-utils.patch9
3 files changed, 14 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20c894a11c94..44413750c8f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vgmstream-kode54-git
pkgdesc = Library for playback of various streamed audio formats used in video games (kode54's fork)
- pkgver = r1020.r557.gd2fac79
- pkgrel = 3
+ pkgver = r1020.r770.g00e1a5f
+ pkgrel = 1
url = https://gitlab.kode54.net/kode54/vgmstream
arch = i686
arch = x86_64
@@ -11,10 +11,9 @@ pkgbase = vgmstream-kode54-git
depends = libogg
depends = libvorbis
depends = mpg123
+ depends = ffmpeg
source = vgmstream-kode54-git::git+https://gitlab.kode54.net/kode54/vgmstream.git
- source = libcoding-utils.patch
sha256sums = SKIP
- sha256sums = 3ae17fca859443b8d75dde83fa511111dee016e5bf2c5cb86c6786929ee30da3
pkgname = vgmstream-kode54-git
diff --git a/PKGBUILD b/PKGBUILD
index eebcab0e9735..ec63d7562f11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
pkgname=vgmstream-kode54-git
-pkgver=r1020.r557.gd2fac79
-pkgrel=3
+pkgver=r1020.r770.g00e1a5f
+pkgrel=1
pkgdesc="Library for playback of various streamed audio formats used in video games (kode54's fork)"
arch=(i686 x86_64)
url='https://gitlab.kode54.net/kode54/vgmstream'
license=(BSD)
-depends=(glibc libogg libvorbis mpg123)
+depends=(glibc libogg libvorbis mpg123 ffmpeg)
makedepends=(git)
-source=(${pkgname}::git+https://gitlab.kode54.net/kode54/vgmstream.git
- libcoding-utils.patch)
-sha256sums=('SKIP'
- '3ae17fca859443b8d75dde83fa511111dee016e5bf2c5cb86c6786929ee30da3')
+source=(${pkgname}::git+https://gitlab.kode54.net/kode54/vgmstream.git)
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -22,24 +20,24 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
- patch -Np0 -i "$srcdir/libcoding-utils.patch"
# We won't build the Audacious plugin so we don't need the libraries either.
- sed -i '/PKG_CHECK_MODULES(\(AUDACIOUS\|GTK\)/{N;N;d}' configure.in
+ sed -i '/PKG_CHECK_MODULES(\(AUDACIOUS\|GTK\)/{N;N;d}' configure.ac
}
build() {
cd "$srcdir/$pkgname"
./bootstrap
- CFLAGS="$CFLAGS -I../ext_includes -I../../ext_includes" ./configure
+ CFLAGS="$CFLAGS -DVGM_USE_FFMPEG" LIBS="-lavcodec -lavformat -lavutil" ./configure
cd src
- make -f Makefile.unix
- "${CC-cc}" "$CFLAGS" -lvorbisfile -lmpg123 -shared -o .libs/libvgmstream.so .libs/*.o */.libs/*.o
+ make -f Makefile.audacious
+ "${CC-cc}" "$CFLAGS" -lvorbisfile -lmpg123 -lavcodec -lavformat -lavutil -shared -o .libs/libvgmstream.so .libs/*.o */.libs/*.o ../ext_libs/.libs/*.o
}
package() {
cd "$srcdir/$pkgname"
- install -D -m644 -t "$pkgdir/usr/include/vgmstream" src/{vgmstream,stream{file,types},util}.h ext_includes/clHCA.h
+ install -D -m644 -t "$pkgdir/usr/include" ext_includes/clHCA.h
+ install -D -m644 -t "$pkgdir/usr/include/vgmstream" src/{vgmstream,stream{file,types},util}.h
install -D -m644 -t "$pkgdir/usr/include/vgmstream/coding" src/coding/{{acm,nwa}_decoder,g72x_state}.h
install -D -m644 -t "$pkgdir/usr/lib" src/.libs/libvgmstream.{a,so}
install -D -m644 -t "$pkgdir/usr/share/licenses/$pkgname" COPYING
diff --git a/libcoding-utils.patch b/libcoding-utils.patch
deleted file mode 100644
index a4323f91d341..000000000000
--- a/libcoding-utils.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- src/coding/Makefile.unix.am 2017-05-03 14:33:52.616081736 +0300
-+++ src/coding/Makefile.unix.am 2017-05-03 14:35:17.252218027 +0300
-@@ -35,5 +35,6 @@
- libcoding_la_SOURCES += wwise_vorbis_decoder.c
- libcoding_la_SOURCES += wwise_vorbis_utils.c
- libcoding_la_SOURCES += ogl_vorbis_decoder.c
-+libcoding_la_SOURCES += coding_utils.c
-
- EXTRA_DIST = coding.h g72x_state.h clHCA.h